summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-17 00:24:39 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-17 08:09:45 +0200
commitf573d19bc059eacd037d2ea656b67e14dcaafa2d (patch)
tree3abe7b53ee35cfb7527bdfc70b129ee28a63802d /kde-frameworks/purpose
parentkde-misc/latte-dock: 0.8.8 version bump (diff)
downloadgentoo-f573d19bc059eacd037d2ea656b67e14dcaafa2d.tar.gz
gentoo-f573d19bc059eacd037d2ea656b67e14dcaafa2d.tar.bz2
gentoo-f573d19bc059eacd037d2ea656b67e14dcaafa2d.zip
kde-frameworks: Add KDE Frameworks 5.57.0
Package-Manager: Portage-2.3.63, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.57.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index bbe049b4cdad..de5f81a9d4f5 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.54.0.tar.xz 142684 BLAKE2B 51dd914668d05513bc325305ac6c23e083b3a18f070681db04149732362a81199fdae89f9e5b00d711a68465ba32fd0c0e41e75f2c175db266a1b07ef2be749d SHA512 548b42fee675f112dfa1d6fd8ab1c8944190417f3d27d7ebbce6826bb50bdc9c560b02c665a51d0ac5e37fcbf0778318a03bad31cae076dc6c53f2139786edbb
DIST purpose-5.56.0.tar.xz 143832 BLAKE2B 1e04d9b0f5ac6e822625ec28949ce71bf3396014315c7da5b2d506ab664980b1b25ff5dbc1afc8125beffbea302be56f9d91c864a2905b175c3bc6cc7614b956 SHA512 afdcb9ed4867f71e1beb6e98159c3be198f6a1ae870595dade0cc767c780adcb5c6d62f64b53757ad50f86f401d01b6a0f18383c2c6329978ee4440ee2a8135f
+DIST purpose-5.57.0.tar.xz 145332 BLAKE2B 82b7afbc83e662c398f9e06bd79060ed28d71d67f0a74546385a230076d17e2d6e0b929929e1ca3ad1322952eb6b15ccf04fb07c0bafd873a1cbaf182a52f1ac SHA512 6a9bb0e19b4e147730fd8b0fb5116f51e9dd2d8bf74fa1b93e9758f3b776c4c1da9e7ff75d8871e28db52b016dbb3d6d1b8c3c046adbdc9c85c1cc1df74188e4
diff --git a/kde-frameworks/purpose/purpose-5.57.0.ebuild b/kde-frameworks/purpose/purpose-5.57.0.ebuild
new file mode 100644
index 000000000000..37030099e575
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.57.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_QTHELP="false"
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+kaccounts"
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ kaccounts? (
+ $(add_kdeapps_dep kaccounts-integration)
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}"
+
+# requires running environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package kaccounts KAccounts)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst(){
+ kde5_pkg_postinst
+
+ if ! has_version "kde-misc/kdeconnect[app]" ; then
+ elog "Optional runtime dependency:"
+ elog "kde-misc/kdeconnect[app] (send through KDE Connect)"
+ fi
+}