summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-frameworks/sonnet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/metadata.xml9
-rw-r--r--kde-frameworks/sonnet/sonnet-5.12.0.ebuild31
3 files changed, 41 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
new file mode 100644
index 000000000000..b0e575057a2a
--- /dev/null
+++ b/kde-frameworks/sonnet/Manifest
@@ -0,0 +1 @@
+DIST sonnet-5.12.0.tar.xz 274688 SHA256 345446f795c9d63c24a93c56424f2a7a40c0376b6556a62872f51c92f46a25e7 SHA512 1214507298ae9f9d61b50c6d873d7f8b280dd4629e73547574329fa52f3f31fefa6c87b6405f74dc17af3caa5eef4d768a3acf2a26ecb1cdc9459feda8a4e374 WHIRLPOOL bc8505d6f2ae1b3e19d5728594a1981aa88464a2738ea996185a344cb222968a24324e09a0ab4211a1df00a0089d95055bff17574113aa46dcb4521a1c28374e
diff --git a/kde-frameworks/sonnet/metadata.xml b/kde-frameworks/sonnet/metadata.xml
new file mode 100644
index 000000000000..e95d265d90ac
--- /dev/null
+++ b/kde-frameworks/sonnet/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="aspell">Enable the app-text/aspell spell-checking backend</flag>
+ <flag name="hunspell">Enable the app-text/hunspell spell-checking backend</flag>
+ </use>
+</pkgmetadata>
diff --git a/kde-frameworks/sonnet/sonnet-5.12.0.ebuild b/kde-frameworks/sonnet/sonnet-5.12.0.ebuild
new file mode 100644
index 000000000000..167ffd7060d8
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.12.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking capabilities through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="+aspell hunspell nls"
+
+RDEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )
+"
+DEPEND="${RDEPEND}
+ nls? ( dev-qt/linguist-tools:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell)
+ $(cmake-utils_use_find_package hunspell)
+ )
+
+ kde5_src_configure
+}