summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-05 23:50:11 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-06 11:15:31 +0100
commit5fbb5fe7a9f80a67ec2b6c028306c4dd3de9a17b (patch)
treeeecb9b4a8aaec33fd34806632ccfcdd853bb759b /kde-frameworks
parentapp-text/scdoc: New package (diff)
downloadgentoo-5fbb5fe7a9f80a67ec2b6c028306c4dd3de9a17b.tar.gz
gentoo-5fbb5fe7a9f80a67ec2b6c028306c4dd3de9a17b.tar.bz2
gentoo-5fbb5fe7a9f80a67ec2b6c028306c4dd3de9a17b.zip
dev-libs/purpose: pkgmove to kde-frameworks/purpose
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/metadata.xml11
-rw-r--r--kde-frameworks/purpose/purpose-1.2.1.ebuild60
3 files changed, 72 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
new file mode 100644
index 000000000000..fc00c57ca6a6
--- /dev/null
+++ b/kde-frameworks/purpose/Manifest
@@ -0,0 +1 @@
+DIST purpose-1.2.1.tar.xz 114408 BLAKE2B 99d5eff18fd66b0823c36381281229705c54d4266926ce02cdcff4899c2431b8c3aa97667dab19824676b72c456cea2bf56a032d6137f2c9c207d724196fb262 SHA512 39747f5043e09f198bbec25d011a45c54cb681fd564ade25016f1b898a3fa4d545f29dc96ca421c266414d375d6b95259f59292255dfb73af777ff62a96ba249
diff --git a/kde-frameworks/purpose/metadata.xml b/kde-frameworks/purpose/metadata.xml
new file mode 100644
index 000000000000..69186b245f38
--- /dev/null
+++ b/kde-frameworks/purpose/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <use>
+ <flag name="kaccounts">Enable support for system-wide defined KAccounts</flag>
+ </use>
+</pkgmetadata>
diff --git a/kde-frameworks/purpose/purpose-1.2.1.ebuild b/kde-frameworks/purpose/purpose-1.2.1.ebuild
new file mode 100644
index 000000000000..06e55ebd995a
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-1.2.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_AUTODEPS="false"
+KDE_QTHELP="false"
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="amd64 ~arm x86"
+IUSE="+kaccounts"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcoreaddons '' 5.40.0)
+ $(add_frameworks_dep ki18n '' 5.40.0)
+ $(add_frameworks_dep kio '' 5.40.0)
+ $(add_qt_dep qtcore)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ kaccounts? (
+ $(add_kdeapps_dep kaccounts-integration)
+ net-libs/accounts-qt
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep extra-cmake-modules '' 5.40.0)
+"
+RDEPEND="${COMMON_DEPEND}
+ >=kde-frameworks/kf-env-4
+ || ( $(add_frameworks_dep breeze-icons '' 5.40.0) kde-frameworks/oxygen-icons:* )
+"
+
+# requires running environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package kaccounts KAccounts)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst(){
+ kde5_pkg_postinst
+
+ if ! has_version "kde-misc/kdeconnect[app]" ; then
+ elog
+ elog "Optional runtime dependency:"
+ elog "kde-misc/kdeconnect[app] (send through KDE Connect)"
+ elog
+ fi
+}