summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-30 09:57:35 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-30 09:58:22 +0200
commit9396df7cac1d2cf85a964541573c758ad256166c (patch)
treeeda1d6675badc98a1cbb51867d6ef425d99236a9 /kde-frameworks
parentkde-apps/kleopatra: Fix CVE-2020-24972 (diff)
downloadgentoo-9396df7cac1d2cf85a964541573c758ad256166c.tar.gz
gentoo-9396df7cac1d2cf85a964541573c758ad256166c.tar.bz2
gentoo-9396df7cac1d2cf85a964541573c758ad256166c.zip
kde-frameworks/purpose: Add missing xdg_icon_cache_update
Closes: https://bugs.gentoo.org/739538 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/purpose/purpose-5.73.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/kde-frameworks/purpose/purpose-5.73.0.ebuild b/kde-frameworks/purpose/purpose-5.73.0.ebuild
index 53c1c4293f2d..1549b21bb7aa 100644
--- a/kde-frameworks/purpose/purpose-5.73.0.ebuild
+++ b/kde-frameworks/purpose/purpose-5.73.0.ebuild
@@ -7,7 +7,7 @@ ECM_QTHELP="false"
ECM_TEST="forceoptional"
PVCUT=$(ver_cut 1-2)
QTMIN=5.14.2
-inherit ecm kde.org
+inherit ecm kde.org xdg-utils
DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
LICENSE="LGPL-2.1+"
@@ -48,11 +48,16 @@ src_configure() {
ecm_src_configure
}
-pkg_postinst(){
+pkg_postinst() {
ecm_pkg_postinst
+ xdg_icon_cache_update
if ! has_version "kde-misc/kdeconnect[app]" ; then
elog "Optional runtime dependency:"
elog "kde-misc/kdeconnect[app] (send through KDE Connect)"
fi
}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}