summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-12-16 20:13:56 +0100
committerJohannes Huber <johu@gentoo.org>2016-12-16 20:13:56 +0100
commite64126abc99a8d2781eb1b05989d4a8b0bd63178 (patch)
treea631a16cc79fee42eb227b7dd768a4bd71f24ca5 /kde-misc/akonadi-ews/akonadi-ews-0.8.1.ebuild
parentkde-misc/zanshin: Version bump 0.4.1 (diff)
downloadgentoo-e64126abc99a8d2781eb1b05989d4a8b0bd63178.tar.gz
gentoo-e64126abc99a8d2781eb1b05989d4a8b0bd63178.tar.bz2
gentoo-e64126abc99a8d2781eb1b05989d4a8b0bd63178.zip
kde-misc/akonadi-ews: New package
Import from kde overlay. Initial ebuild by Krzysztof Nowicki <krissn@op.pl>. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-misc/akonadi-ews/akonadi-ews-0.8.1.ebuild')
-rw-r--r--kde-misc/akonadi-ews/akonadi-ews-0.8.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-misc/akonadi-ews/akonadi-ews-0.8.1.ebuild b/kde-misc/akonadi-ews/akonadi-ews-0.8.1.ebuild
new file mode 100644
index 000000000000..0de24d72deaf
--- /dev/null
+++ b/kde-misc/akonadi-ews/akonadi-ews-0.8.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Akonadi resource for Microsoft Exchange Web Services"
+HOMEPAGE="https://github.com/KrissN/akonadi-ews"
+
+if [[ ${KDE_BUILD_TYPE} = live ]] ; then
+ EGIT_REPO_URI="https://github.com/KrissN/${PN}.git"
+else
+ SRC_URI="https://github.com/KrissN/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kmime)
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt"
+
+DOCS=( README.md )