summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-07-03 15:55:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-07-04 15:53:00 +0200
commit9990749ed42f72c1b02e00e4475b4ebb721fae07 (patch)
tree3ec7204ef4af92def81e5a3981f817671249f3ce /kde-misc/kio-stash
parentnet-misc/kafka-bin: Bump (diff)
downloadgentoo-9990749ed42f72c1b02e00e4475b4ebb721fae07.tar.gz
gentoo-9990749ed42f72c1b02e00e4475b4ebb721fae07.tar.bz2
gentoo-9990749ed42f72c1b02e00e4475b4ebb721fae07.zip
kde-misc/kio-stash: Drop bogus DEPEND
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'kde-misc/kio-stash')
-rw-r--r--kde-misc/kio-stash/files/kio-stash-1.0-no-kf5config.patch43
-rw-r--r--kde-misc/kio-stash/kio-stash-1.0.ebuild3
2 files changed, 45 insertions, 1 deletions
diff --git a/kde-misc/kio-stash/files/kio-stash-1.0-no-kf5config.patch b/kde-misc/kio-stash/files/kio-stash-1.0-no-kf5config.patch
new file mode 100644
index 000000000000..1e434bb625ea
--- /dev/null
+++ b/kde-misc/kio-stash/files/kio-stash-1.0-no-kf5config.patch
@@ -0,0 +1,43 @@
+commit 624a1f38b9604def78c34e26ac31e1fd21c6673b
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Mon Jul 3 20:36:41 2017 +0200
+
+ Drop unused KF5Config dependency
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0cbd710..1552df6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -27,7 +27,6 @@ find_package(Qt5 ${QT5_MIN_VERSION} REQUIRED COMPONENTS
+ )
+
+ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
+- Config
+ KIO
+ DBusAddons
+ I18n
+diff --git a/src/ioslave/CMakeLists.txt b/src/ioslave/CMakeLists.txt
+index 462fef9..23922f8 100644
+--- a/src/ioslave/CMakeLists.txt
++++ b/src/ioslave/CMakeLists.txt
+@@ -6,8 +6,6 @@ target_link_libraries (kio_filestash
+ Qt5::DBus
+ KF5::KIOCore
+ KF5::I18n
+- KF5::ConfigCore
+- KF5::ConfigGui
+ )
+
+ set_target_properties(kio_filestash PROPERTIES OUTPUT_NAME "filestash")
+diff --git a/src/ioslave/ioslave.cpp b/src/ioslave/ioslave.cpp
+index b280f11..8928efb 100644
+--- a/src/ioslave/ioslave.cpp
++++ b/src/ioslave/ioslave.cpp
+@@ -34,7 +34,6 @@
+
+ #include <KProtocolManager>
+ #include <KLocalizedString>
+-#include <KConfigGroup>
+ #include <KFileItem>
+ #include <KIO/Job>
+
diff --git a/kde-misc/kio-stash/kio-stash-1.0.ebuild b/kde-misc/kio-stash/kio-stash-1.0.ebuild
index 88a528d43dfd..a0b34b7c1542 100644
--- a/kde-misc/kio-stash/kio-stash-1.0.ebuild
+++ b/kde-misc/kio-stash/kio-stash-1.0.ebuild
@@ -18,7 +18,6 @@ IUSE=""
RESTRICT+=" test"
DEPEND="
- $(add_frameworks_dep kconfig)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep ki18n)
@@ -26,3 +25,5 @@ DEPEND="
$(add_qt_dep qtdbus)
"
RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-no-kf5config.patch" )