summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/wicd-client-kde/wicd-client-kde-0.3.1-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/wicd-client-kde/wicd-client-kde-0.3.1-r1.ebuild')
-rw-r--r--kde-misc/wicd-client-kde/wicd-client-kde-0.3.1-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/kde-misc/wicd-client-kde/wicd-client-kde-0.3.1-r1.ebuild b/kde-misc/wicd-client-kde/wicd-client-kde-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..bb8a0eb5bd34
--- /dev/null
+++ b/kde-misc/wicd-client-kde/wicd-client-kde-0.3.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# Incompatible linguas handling
+# KDE_LINGUAS="cs da de el en_GB es et fr hu it lt nb nds nl pa pl pt pt_BR ru sv
+# uk zh_CN zh_TW"
+EGIT_REPONAME="wicd-kde"
+MY_P=${P/-client/}
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 kde4-base
+
+DESCRIPTION="Wicd client built on the KDE Development Platform"
+HOMEPAGE="http://kde-apps.org/content/show.php/Wicd+Client+KDE?content=132366"
+[[ ${PV} == *9999 ]] || \
+ SRC_URI="http://kde-apps.org/CONTENT/content-files/132366-${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ net-misc/wicd"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN/-client/}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPYTHONBIN=/usr/bin/python2
+ )
+
+ kde4-base_src_configure
+}