summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-12-20 21:29:21 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-12-21 23:32:20 +1100
commit5bfec586f35169bb33eecb287382f2c2b536857f (patch)
tree8f6b686cfddb795f409e580ddb948207f10c7e97 /kde-misc
parentkde-apps/korganizer: Drop old (diff)
downloadgentoo-5bfec586f35169bb33eecb287382f2c2b536857f.tar.gz
gentoo-5bfec586f35169bb33eecb287382f2c2b536857f.tar.bz2
gentoo-5bfec586f35169bb33eecb287382f2c2b536857f.zip
kde-misc/zanshin: Add missing RDEPEND
Needs kde-apps/kdepim-runtime for akonadi resources Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/zanshin/zanshin-0.4.1-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/kde-misc/zanshin/zanshin-0.4.1-r1.ebuild b/kde-misc/zanshin/zanshin-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..025035e2aab8
--- /dev/null
+++ b/kde-misc/zanshin/zanshin-0.4.1-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_MIN_VERSION="3.2.0"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Getting things done application by KDE"
+HOMEPAGE="https://zanshin.kde.org/"
+[[ ${KDE_BUILD_TYPE} != live ]] && SRC_URI="http://files.kde.org/zanshin/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# FIXME: bundles libkdepim
+COMMON_DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep krunner)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep akonadi-notes)
+ $(add_kdeapps_dep akonadi-search)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kldap)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep kontactinterface)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ dev-libs/boost
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( $(add_kdeapps_dep akonadi 'tools') )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-misc/zanshin:4
+ $(add_kdeapps_dep kdepim-runtime)
+"