summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-22 14:12:07 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-22 15:02:03 +0100
commit8f8fce40fe9e5386460dc4246360e60bc486787b (patch)
treeaa90de4adbc813588a191fa727835fbd0a532fac /kde-misc
parentdev-cpp/eigen: 3.3.7 version bump (diff)
downloadgentoo-8f8fce40fe9e5386460dc4246360e60bc486787b.tar.gz
gentoo-8f8fce40fe9e5386460dc4246360e60bc486787b.tar.bz2
gentoo-8f8fce40fe9e5386460dc4246360e60bc486787b.zip
kde-misc/yakuake: Add USE absolute-position, X
Add several post-release fixes while at it. Closes: https://bugs.gentoo.org/672520 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/yakuake/Manifest1
-rw-r--r--kde-misc/yakuake/metadata.xml9
-rw-r--r--kde-misc/yakuake/yakuake-3.0.5-r1.ebuild65
3 files changed, 69 insertions, 6 deletions
diff --git a/kde-misc/yakuake/Manifest b/kde-misc/yakuake/Manifest
index da483e10427e..0b9717ab7366 100644
--- a/kde-misc/yakuake/Manifest
+++ b/kde-misc/yakuake/Manifest
@@ -1 +1,2 @@
+DIST yakuake-3.0.5-patches.tar.xz 4996 BLAKE2B 0ffef1bf066b962c73ef6a28251d9abf3df66b28cf324bcd2d4f49c7038ba64dd3554490534cb0b001a589c42309253a0cf77683b4f97661d0fbfc17c96e5be0 SHA512 6c66043e22e98d65230de566e4594f4c1bfdcccc229ab8b66d604bf6fa666964f8b05746eb914f65d1e52fa850010aa5016a26b629f8eec09b67548dd2b00251
DIST yakuake-3.0.5.tar.xz 347412 BLAKE2B 964b5abdbc377b2ff3c1c37ebf4cb2537dde00d8c4178bc7db1785701dee82c600cd775a38896d8ad8976cbe14427df094c4db0c425355b0330d2e8b4fbe23cd SHA512 17640590bb87b7c27e1e336cb82141b986103af95cfae2da129b69537d89a78eb0e21a6f5fb9ab26ed9e572f9edad055264f642afee6012e1a5a5c55d9dc2d22
diff --git a/kde-misc/yakuake/metadata.xml b/kde-misc/yakuake/metadata.xml
index daa15bc80c29..b62c302261a7 100644
--- a/kde-misc/yakuake/metadata.xml
+++ b/kde-misc/yakuake/metadata.xml
@@ -5,10 +5,7 @@
<email>kde@gentoo.org</email>
<name>Gentoo KDE Project</name>
</maintainer>
- <longdescription>
- YaKuake is Yet Another Kuake KDE terminal emulator. It drops down on a
- configurable key press (defaults to F12) with a konsole window, supports
- multiple tabs, multiple screens and mouse wheel tab navigation amongst other
- features.
- </longdescription>
+ <use>
+ <flag name="absolute-position">Use <pkg>kde-frameworks/kwayland</pkg> for absolute window positioning in KWin</flag>
+ </use>
</pkgmetadata>
diff --git a/kde-misc/yakuake/yakuake-3.0.5-r1.ebuild b/kde-misc/yakuake/yakuake-3.0.5-r1.ebuild
new file mode 100644
index 000000000000..d3b012992719
--- /dev/null
+++ b/kde-misc/yakuake/yakuake-3.0.5-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Quake-style terminal emulator based on konsole"
+HOMEPAGE="https://yakuake.kde.org/"
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz
+ https://dev.gentoo.org/~asturm/distfiles/${P}-patches.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2"
+IUSE="absolute-position X"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep konsole)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ absolute-position? ( $(add_frameworks_dep kwayland) )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ )
+"
+RDEPEND="${DEPEND}
+ !kde-misc/yakuake:4
+"
+
+PATCHES=(
+ "${WORKDIR}/${P}-patches/${P}-kmainwindow.patch"
+ "${WORKDIR}/${P}-patches/${P}-qicon.patch"
+ "${WORKDIR}/${P}-patches/${P}-kwindowsystem.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package absolute-position KF5Wayland)
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}