summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-12 20:39:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-12 20:41:48 +0100
commit30026b45f60eff6506c3385a4c85c7d7b64958e5 (patch)
tree9047352a4c753df82973e1ce93ccb63904a2ae34 /kde-plasma/kde-gtk-config
parentRevert "net-irc/irssi: Restore some random keywords" (diff)
downloadgentoo-30026b45f60eff6506c3385a4c85c7d7b64958e5.tar.gz
gentoo-30026b45f60eff6506c3385a4c85c7d7b64958e5.tar.bz2
gentoo-30026b45f60eff6506c3385a4c85c7d7b64958e5.zip
kde-plasma: Add KDE Plasma 5.15.0
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kde-gtk-config')
-rw-r--r--kde-plasma/kde-gtk-config/Manifest1
-rw-r--r--kde-plasma/kde-gtk-config/kde-gtk-config-5.15.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/kde-plasma/kde-gtk-config/Manifest b/kde-plasma/kde-gtk-config/Manifest
index a805ffab596a..778cb72d97ef 100644
--- a/kde-plasma/kde-gtk-config/Manifest
+++ b/kde-plasma/kde-gtk-config/Manifest
@@ -1 +1,2 @@
DIST kde-gtk-config-5.14.5.tar.xz 157032 BLAKE2B b13e44fbe1ea048e58b98f1396528372f74545effa145b65a71709f1e7732c0ed48111e52eaafc544d180678e411df20786a0f9cfee1557c1df873b4630e380f SHA512 3bb350307cabf44a27dcc3be95c8d2c15049be80f3c3fb127ddaaf9880acb850f10126347fba07868bfa9424d5e1c92b580687aa356be2869ff36684a15d8563
+DIST kde-gtk-config-5.15.0.tar.xz 156264 BLAKE2B bc20d4a14d637fcc595e638216d1aec94e84daf307d6bf741ccb8948f2361e5b27bf1dbddefdd08b21cef1c81acc3f24e6be66f99db78acabe988ebb1c47ccd3 SHA512 fdd47b09d8cc4740970b10e793fd6fb2c8fe9ad47d1f28d29ea573caaf6285650215bdd7fef8199eba6c26a8db96df8908e58b1743438eb36574a21596b032d3
diff --git a/kde-plasma/kde-gtk-config/kde-gtk-config-5.15.0.ebuild b/kde-plasma/kde-gtk-config/kde-gtk-config-5.15.0.ebuild
new file mode 100644
index 000000000000..fc191b3a9ec5
--- /dev/null
+++ b/kde-plasma/kde-gtk-config/kde-gtk-config-5.15.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Plasma systemsettings kcm to set GTK application look&feel"
+HOMEPAGE="https://cgit.kde.org/kde-gtk-config.git"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/glib:2
+ gnome-base/gsettings-desktop-schemas
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ x11-libs/libXcursor
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDATA_INSTALL_DIR="${EPREFIX}/usr/share"
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "If you notice missing icons in your GTK applications, you may have to install"
+ elog "the corresponding themes for GTK. A good guess would be x11-themes/oxygen-gtk"
+ elog "for example."
+}