summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-plasma/kde-gtk-config
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-plasma/kde-gtk-config')
-rw-r--r--kde-plasma/kde-gtk-config/Manifest1
-rw-r--r--kde-plasma/kde-gtk-config/kde-gtk-config-5.3.2.ebuild52
-rw-r--r--kde-plasma/kde-gtk-config/metadata.xml5
3 files changed, 58 insertions, 0 deletions
diff --git a/kde-plasma/kde-gtk-config/Manifest b/kde-plasma/kde-gtk-config/Manifest
new file mode 100644
index 000000000000..ea277b8f3cdc
--- /dev/null
+++ b/kde-plasma/kde-gtk-config/Manifest
@@ -0,0 +1 @@
+DIST kde-gtk-config-5.3.2.tar.xz 143520 SHA256 55bc964dda26620bfe64731435f72a87dedd530d486d7c0dd856aeadd1f68467 SHA512 007ffe8f6ba7675eb827a82dd2cb7e501d6833fb83e636ed120d2c32248c3a7fdc35807e6dcd5adc7476506814e2c02e6cbb6e7d7123c1158780be39504e7236 WHIRLPOOL cfd3dcc652b1bc07bcbe8d090b73e7c266d03e6d2707debea02b0223b9858081b6a053503df440f05355d3cb32478aaa617db555b21ff3601fc1282ced765ba2
diff --git a/kde-plasma/kde-gtk-config/kde-gtk-config-5.3.2.ebuild b/kde-plasma/kde-gtk-config/kde-gtk-config-5.3.2.ebuild
new file mode 100644
index 000000000000..72ca2cbc893e
--- /dev/null
+++ b/kde-plasma/kde-gtk-config/kde-gtk-config-5.3.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_PUNT_BOGUS_DEPS="true"
+inherit kde5
+
+DESCRIPTION="KDE systemsettings kcm to set GTK application look&feel"
+HOMEPAGE="http://projects.kde.org/kde-gtk-config"
+LICENSE="GPL-3"
+KEYWORDS="~amd64"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kwidgetsaddons)
+ dev-libs/glib:2
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-base/kde-gtk-config
+ !kde-misc/kde-gtk-config
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDATA_INSTALL_DIR="${EPREFIX}/usr/share"
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ einfo
+ elog "If you notice missing icons in your GTK applications, you may have to install"
+ elog "the corresponding themes for GTK. A good guess would be x11-themes/oxygen-gtk"
+ elog "for example."
+ einfo
+}
diff --git a/kde-plasma/kde-gtk-config/metadata.xml b/kde-plasma/kde-gtk-config/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/kde-plasma/kde-gtk-config/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>