summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-08 13:40:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-08 14:32:55 +0100
commit5e0f583660d70d633152b9639af6b52e6f690090 (patch)
tree361e6c35245cbfb031ee399a9d3d441768480d8e /kde-plasma/kde-gtk-config
parentdev-lang/ruby: Added sys-libs/readline to RDEPEND. (diff)
downloadgentoo-5e0f583660d70d633152b9639af6b52e6f690090.tar.gz
gentoo-5e0f583660d70d633152b9639af6b52e6f690090.tar.bz2
gentoo-5e0f583660d70d633152b9639af6b52e6f690090.zip
kde-plasma: Add KDE Plasma 5.14.5
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kde-gtk-config')
-rw-r--r--kde-plasma/kde-gtk-config/Manifest1
-rw-r--r--kde-plasma/kde-gtk-config/kde-gtk-config-5.14.5.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/kde-gtk-config/Manifest b/kde-plasma/kde-gtk-config/Manifest
index b9e3a80f9591..f658df066718 100644
--- a/kde-plasma/kde-gtk-config/Manifest
+++ b/kde-plasma/kde-gtk-config/Manifest
@@ -1,2 +1,3 @@
DIST kde-gtk-config-5.14.3.tar.xz 157292 BLAKE2B fd060e1810058472e24a82819c2b3b737637d8a5430912e22511085c0c361ccc5f355f7d1235d9514dabdaede799528f5522fd83b452c33e06689c70ada3502e SHA512 5c8d14d77cd6707d32f09361247445ff4399bb7331125d795bf2046bd7f8467c374ad68a11899bcc1592c9c207a4f94e9ef523074184550577c9c85fa7de49ef
DIST kde-gtk-config-5.14.4.tar.xz 156960 BLAKE2B 43c986887746c3e7ad1ccf9220d0f9356e3b32c2064267e94df3994f128df05712d4dc594b753afa90780597336501206fa367542593a9dd9660212fadeb403e SHA512 37c00a7fe1e7b6d5c502c1a075617187daca3a43657ed119b16e498002f3a3f23beb53062391c825d6bbd48374cfd6a9334d98bc5046a9561f93da89a32428db
+DIST kde-gtk-config-5.14.5.tar.xz 157032 BLAKE2B b13e44fbe1ea048e58b98f1396528372f74545effa145b65a71709f1e7732c0ed48111e52eaafc544d180678e411df20786a0f9cfee1557c1df873b4630e380f SHA512 3bb350307cabf44a27dcc3be95c8d2c15049be80f3c3fb127ddaaf9880acb850f10126347fba07868bfa9424d5e1c92b580687aa356be2869ff36684a15d8563
diff --git a/kde-plasma/kde-gtk-config/kde-gtk-config-5.14.5.ebuild b/kde-plasma/kde-gtk-config/kde-gtk-config-5.14.5.ebuild
new file mode 100644
index 000000000000..1b8010dcde5d
--- /dev/null
+++ b/kde-plasma/kde-gtk-config/kde-gtk-config-5.14.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Plasma systemsettings kcm to set GTK application look&feel"
+HOMEPAGE="https://cgit.kde.org/kde-gtk-config.git"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/glib:2
+ gnome-base/gsettings-desktop-schemas
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ x11-libs/libXcursor
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-plasma/kde-gtk-config:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDATA_INSTALL_DIR="${EPREFIX}/usr/share"
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "If you notice missing icons in your GTK applications, you may have to install"
+ elog "the corresponding themes for GTK. A good guess would be x11-themes/oxygen-gtk"
+ elog "for example."
+}