summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-29 21:43:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-29 23:21:35 +0100
commit484c9dded4c2473cc9cf94f0ea2f4b87ae3ee5fd (patch)
tree38d93021acd0016cf8d9e739e232b856cdaace75 /kde-plasma/kdeplasma-addons
parentprofiles: arm64: Add kde-plasma/plasma-meta[thunderbolt] to p.use.mask (diff)
downloadgentoo-484c9dded4c2473cc9cf94f0ea2f4b87ae3ee5fd.tar.gz
gentoo-484c9dded4c2473cc9cf94f0ea2f4b87ae3ee5fd.tar.bz2
gentoo-484c9dded4c2473cc9cf94f0ea2f4b87ae3ee5fd.zip
kde-plasma: Add KDE Plasma 5.17.2
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kdeplasma-addons')
-rw-r--r--kde-plasma/kdeplasma-addons/Manifest1
-rw-r--r--kde-plasma/kdeplasma-addons/kdeplasma-addons-5.17.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/kde-plasma/kdeplasma-addons/Manifest b/kde-plasma/kdeplasma-addons/Manifest
index 4e55f3e89ada..dd0cb64b472d 100644
--- a/kde-plasma/kdeplasma-addons/Manifest
+++ b/kde-plasma/kdeplasma-addons/Manifest
@@ -1,2 +1,3 @@
DIST kdeplasma-addons-5.16.5.tar.xz 600480 BLAKE2B 146c7ba77eb4ff973afb5e051d3000baebdea317b9e17482fa07cf575b2d4d8bce69590c66b0b4756cb971109ff701e8786a25108729aa7d65bdcb89cc945a40 SHA512 0bcbff113d71bb33a6542d78a250dacb8eff66c5f8bc84f9ec0055fe74ccb7ad2b5706ef3782e754909c75a95b133f3233b93cd7290d354df1d54dca1401d875
DIST kdeplasma-addons-5.17.1.tar.xz 605376 BLAKE2B 5a997ffc9049f6b1b3114272d330b387094bd2d123b264d353020cb2ea68240f91c5c7723021cd49ec4ae527e36eb82462c49c75f15416c62b97c1334f9b8ab3 SHA512 68054daf01d1c4ba3947eba2cbb7c88394c5fc8218fa36b832bd276aef83193833b4a19fd29a98933fa311da1b0b419d6fe6a44610960fb1347ea989b472523e
+DIST kdeplasma-addons-5.17.2.tar.xz 606488 BLAKE2B 43fd4fa556abe9cf925556fcf233073bdc4b83bb781a8c627ea65aeb7d54a8b6387733927877750ac472c3c467b641a5a39ac27cc634d37f19a38865f48aaf0f SHA512 a065bdfeca62d1a951e2452343a0d7dd386af8bdf7865b806345f910b8822ee7960edb9a782876edb6120f446d8ab6375313e36d167ac1dce1794a492d7150a6
diff --git a/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.17.2.ebuild b/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.17.2.ebuild
new file mode 100644
index 000000000000..0d8ba38af27c
--- /dev/null
+++ b/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.17.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Extra Plasma applets and engines"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="share webengine"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kholidays)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kross)
+ $(add_frameworks_dep krunner)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kunitconversion)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep sonnet)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ share? ( $(add_frameworks_dep purpose) )
+ webengine? ( $(add_qt_dep qtwebengine) )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep plasma-workspace)
+ $(add_qt_dep qtquickcontrols)
+ $(add_qt_dep qtquickcontrols2)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package share KF5Purpose)
+ $(cmake-utils_use_find_package webengine Qt5WebEngine)
+ )
+
+ kde5_src_configure
+}