summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-15 16:03:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-23 15:59:11 +0100
commit6c44f9ca36f524f51bfa1fe3bc891c62dc75fb46 (patch)
tree402c5439a9fe1b6d6777b2a98a9ec648978ea2ed /kde-plasma/kdeplasma-addons
parentkde-plasma/breeze-gtk: Drop 5.23.3 (r0) (diff)
downloadgentoo-6c44f9ca36f524f51bfa1fe3bc891c62dc75fb46.tar.gz
gentoo-6c44f9ca36f524f51bfa1fe3bc891c62dc75fb46.tar.bz2
gentoo-6c44f9ca36f524f51bfa1fe3bc891c62dc75fb46.zip
kde-plasma/kdeplasma-addons: mediaframe: fix path URLs
KDE-bug: https://bugs.kde.org/show_bug.cgi?id=445071 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kdeplasma-addons')
-rw-r--r--kde-plasma/kdeplasma-addons/files/kdeplasma-addons-5.23.3-mediaframe-fix-path-URLs.patch31
-rw-r--r--kde-plasma/kdeplasma-addons/kdeplasma-addons-5.23.3-r1.ebuild75
2 files changed, 106 insertions, 0 deletions
diff --git a/kde-plasma/kdeplasma-addons/files/kdeplasma-addons-5.23.3-mediaframe-fix-path-URLs.patch b/kde-plasma/kdeplasma-addons/files/kdeplasma-addons-5.23.3-mediaframe-fix-path-URLs.patch
new file mode 100644
index 000000000000..55fed8152434
--- /dev/null
+++ b/kde-plasma/kdeplasma-addons/files/kdeplasma-addons-5.23.3-mediaframe-fix-path-URLs.patch
@@ -0,0 +1,31 @@
+From 5e16b5ab644748fbf38c2b7fa7113d8dc99bcc28 Mon Sep 17 00:00:00 2001
+From: Patrick Northon <northon_patrick3@yahoo.ca>
+Date: Sun, 7 Nov 2021 20:36:45 -0500
+Subject: [PATCH] [mediaframe] Make files added from paths into URLs.
+
+This make it consistent with individual files added and fix a problem where the url isn't converted to a path properly in some conditions when the url doesn't contain the schema (file://).
+
+BUG: 445071
+
+
+(cherry picked from commit 181cc49c4d44a4ac926051ebf9a53d0a8fc6b253)
+---
+ applets/mediaframe/plugin/mediaframe.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/applets/mediaframe/plugin/mediaframe.cpp b/applets/mediaframe/plugin/mediaframe.cpp
+index 45e37eeae..8729d7b83 100644
+--- a/applets/mediaframe/plugin/mediaframe.cpp
++++ b/applets/mediaframe/plugin/mediaframe.cpp
+@@ -125,7 +125,7 @@ void MediaFrame::add(const QString &path, AddOption option)
+ while (dirIterator.hasNext()) {
+ dirIterator.next();
+
+- filePath = dirIterator.filePath();
++ filePath = "file://" + dirIterator.filePath();
+ paths.append(filePath);
+ m_allFiles.append(filePath);
+ // qDebug() << "Appended" << filePath;
+--
+GitLab
+
diff --git a/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.23.3-r1.ebuild b/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.23.3-r1.ebuild
new file mode 100644
index 000000000000..73d939f3bafb
--- /dev/null
+++ b/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.23.3-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.86.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Extra Plasma applets and engines"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="share webengine"
+
+RESTRICT="test" # bug 727846
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kholidays-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/krunner-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kunitconversion-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ >=kde-frameworks/sonnet-${KFMIN}:5
+ share? ( >=kde-frameworks/purpose-${KFMIN}:5 )
+ webengine? ( >=dev-qt/qtwebengine-${QTMIN}:5 )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-plasma/plasma-workspace-${PVCUT}:5
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-mediaframe-fix-path-URLs.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package share KF5Purpose)
+ $(cmake_use_find_package webengine Qt5WebEngine)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Disk quota applet" sys-fs/quota
+ fi
+ ecm_pkg_postinst
+}