summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-06 21:12:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-07 09:53:59 +0200
commita98fc176b8e977eedb3501cf0617948c22547310 (patch)
tree8cc2b8bc25d8a8e6525b49e531e9a1299553f0a6 /kde-plasma/khotkeys/khotkeys-5.18.5.ebuild
parentdev-python/pebble: Bump to 4.5.2 (diff)
downloadgentoo-a98fc176b8e977eedb3501cf0617948c22547310.tar.gz
gentoo-a98fc176b8e977eedb3501cf0617948c22547310.tar.bz2
gentoo-a98fc176b8e977eedb3501cf0617948c22547310.zip
kde-plasma: Add KDE Plasma 5.18.5
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/khotkeys/khotkeys-5.18.5.ebuild')
-rw-r--r--kde-plasma/khotkeys/khotkeys-5.18.5.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/khotkeys/khotkeys-5.18.5.ebuild b/kde-plasma/khotkeys/khotkeys-5.18.5.ebuild
new file mode 100644
index 000000000000..9259113b2f86
--- /dev/null
+++ b/kde-plasma/khotkeys/khotkeys-5.18.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional" # not optional until !kdelibs4support
+KFMIN=5.66.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="KDE Plasma workspace hotkey module"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdelibs4support-${KFMIN}:5[X]
+ >=kde-frameworks/kglobalaccel-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-plasma/libkworkspace-${PVCUT}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+ x11-libs/libxcb
+ x11-libs/libXtst
+"
+RDEPEND="${COMMON_DEPEND}
+ >=kde-frameworks/kded-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+"