summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-17 18:49:34 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-17 18:49:34 +0200
commitc824c3a371a0909bcde90b960d4d6dadf9a880ce (patch)
tree92de1d03dfc20ba24017e71a97aeacceda950a29 /kde-plasma/kinfocenter
parentprofiles: USE mask LUA for www-servers/nginx on ppc 64bit userland (diff)
downloadgentoo-c824c3a371a0909bcde90b960d4d6dadf9a880ce.tar.gz
gentoo-c824c3a371a0909bcde90b960d4d6dadf9a880ce.tar.bz2
gentoo-c824c3a371a0909bcde90b960d4d6dadf9a880ce.zip
kde-plasma: Add KDE Plasma 5.11.1
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.11.1.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index e7513cbf8862..92b1ce9361d2 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 SHA256 0afc3eca084c327f8059166b86769f03c9c23e1e765bb47dc3229505abbac0c6 SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48 WHIRLPOOL e161bf40c5e16180fa65217cb49314fb230c45329f4c518d6014083bd71da82d4aa048811ee814fde7fa300105cef16c182688445164ae84d0d700e23641b342
DIST kinfocenter-5.10.5.tar.xz 1263864 SHA256 5527a3f1bb608dbaf092747c9e0c1ac24305987f31eb10604a536c73af978e3a SHA512 556bb7e369f28ce1203129f02009bc01d3c018e6e0cc7c3c18382fdc7bb6fa54e9056deb5ffbfcb429853b5f0076e537ce01be721cf698d493a531777ef1225f WHIRLPOOL 13974e560d425cceb17972e711bff87da6d47ef52815b1685eef87a188cbddb9a7be3d584a673f6a14a4ea90196efc7c549479cfae59d346a530dc1194d7a059
DIST kinfocenter-5.11.0.tar.xz 1268060 SHA256 a4aee1158ead6d9c5873db4d245fc9bf9522f72e73983d3bde1bbbc9bce51c87 SHA512 d7cfaf676fc172b113ff60ca9f07b65468e89bfef475821828944aca3884edf7a126d6302253c716c30da2733d081b3b177da53bf5daeb673fd223554b4a983a WHIRLPOOL 1020dcc519e60476d26ee09487b9baeccef1f9f230040ff708686574767a287ddf9e0490621eaefd7bd18f550b91718a3866749405ceea532b0e04548c09cbef
+DIST kinfocenter-5.11.1.tar.xz 1268156 SHA256 88b1da98f2e27edfe8c1d6f55188ffd8512bfad4bbc1db30d978200f0c717047 SHA512 365d525f40822328b4a1acd4444fbade916186c34c87ceb58b245b2ac1a3227289262109b6ce5ed6364448b09a5ba7afe05c22b16c8e72950b8516c18e9c65fa WHIRLPOOL efd41e2512f51524802574fbbaca42cfe1e6944eecb421426e79c084fe18c6706425f57662e33cd220d029acc81a02e5a14bc90319bd7c850e6319161d5bdaaa
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.11.1.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.11.1.ebuild
new file mode 100644
index 000000000000..1acc3e68a9a7
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.11.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="A utility that provides information about a computer system"
+HOMEPAGE="https://www.kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="wayland? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[gles2?]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? (
+ $(add_frameworks_dep kwayland)
+ media-libs/mesa[egl]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-apps/kcontrol:4
+ !kde-misc/about-distro
+ !kde-plasma/kinfocenter:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package gles2 OpenGLES)
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package opengl OpenGL)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland EGL)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if ! has_version "net-fs/nfs-utils"; then
+ einfo "Installing net-fs/nfs-utils will enable the NFS information module."
+ fi
+ if ! has_version "net-fs/samba" || ! has_version "net-fs/samba[server]"; then
+ einfo "Installing net-fs/samba[server(+)] will enable the Samba status information module."
+ fi
+}