summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-19 14:17:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-19 14:17:39 +0100
commite5b6f1e7918fa647bd5e182c7ffaed43785b5ed5 (patch)
tree05955d3b163be1bb5f5042438af1a57e0fda24c7 /kde-plasma/kinfocenter
parentapp-misc/ca-certificates: fix double prefix (diff)
downloadgentoo-e5b6f1e7918fa647bd5e182c7ffaed43785b5ed5.tar.gz
gentoo-e5b6f1e7918fa647bd5e182c7ffaed43785b5ed5.tar.bz2
gentoo-e5b6f1e7918fa647bd5e182c7ffaed43785b5ed5.zip
kde-plasma: Add KDE Plasma 5.15.1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.15.1.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index a0e926812c27..b65c39e2e8d6 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.14.5.tar.xz 1323212 BLAKE2B cf248445aec1320e18f11e58d9e02a95b1535446bc207ed75b76d18ca81af12feac221cf847bf73ecb4e0036432e6055c2801b34b9673ae289330468b2184c94 SHA512 df38b40eef89d4b4a6e7f6e5e72325122c5ed924fa01dd59e6d99ffef61a9bcd89e11dac8412ea0a95ecc0b68469cad6921ad529a247b59aaab3dc7a7d09a04c
DIST kinfocenter-5.15.0.tar.xz 1322604 BLAKE2B 231abe78080a5842b89b1bf3b00c1c86d40d7f7fa640239a791286b4f4dbd9f7cbc8cb76cae104850fd0310cef368621fe74058df1e5920b441f7ac4daf3d66e SHA512 25b68dcf69d6c5bf4c812cecce6fb1b0be6522f19d149b31bd53d4d6e1ec32ae6f37305f5bdaf3ff394121993acff758d6d27286cb02a610ce9f798310448c2b
+DIST kinfocenter-5.15.1.tar.xz 1322104 BLAKE2B bca9c913d6ea6a23f9bd99c5d5468b5aa7d7e3878f5b60a49f3f071947379304a2763e594ded801353723957491f6ceb814f1be05cb98e87b65c6f6ab157094f SHA512 42c5b406267dc498583ed3b8f4a27f5332eb0158d77a20d6223e1535e4075ca522a7e7405b6a25c565364bfd10b2d60ce093486968666afffa1abe137a49f717
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.15.1.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.15.1.ebuild
new file mode 100644
index 000000000000..a937f0caf6e5
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.15.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MAKEFILE_GENERATOR="emake" # FIXME
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://www.kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="wayland? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[gles2?]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? (
+ $(add_frameworks_dep kwayland)
+ media-libs/mesa[egl]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ $(add_qt_dep qtquickcontrols2)
+ !kde-apps/kcontrol:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland EGL)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ if has_version "dev-qt/qtgui[gles2]"; then
+ mycmakeargs+=( $(cmake-utils_use_find_package gles2 OpenGLES) )
+ else
+ mycmakeargs+=( $(cmake-utils_use_find_package opengl OpenGL) )
+ fi
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ has_version "net-fs/nfs-utils" || \
+ elog "Installing net-fs/nfs-utils will enable the NFS information module."
+
+ has_version "net-fs/samba" || \
+ elog "Installing net-fs/samba will enable the Samba status information module."
+ fi
+}