summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-03-29 17:38:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-03-29 17:56:24 +0200
commitf2c797ef92a0fa40d8b356620244b30992ce3129 (patch)
tree0f68604d6b4996d12190f4fc2fdc10cc326f5c70 /kde-plasma/kinfocenter
parentkde-plasma/khotkeys: 5.24.4 version bump (diff)
downloadgentoo-f2c797ef92a0fa40d8b356620244b30992ce3129.tar.gz
gentoo-f2c797ef92a0fa40d8b356620244b30992ce3129.tar.bz2
gentoo-f2c797ef92a0fa40d8b356620244b30992ce3129.zip
kde-plasma/kinfocenter: 5.24.4 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.24.4.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index f71fd51038f8..11f22d1a44f4 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.23.5.tar.xz 1152396 BLAKE2B f30af8e32a43079cd87b52e5d8180ca58f8d5743fa2f26afbc4f7cf70bbb2260929f7bfc0907d03320ff29fd2440968f14fa8185832052194390bd4581a085e1 SHA512 9cb25087587f3b469178424ee991b1832bed23cabcdfe2fc515fb1824ba618ee0cc7e5cd270f9ca348f90ceac68f5758d0c7d690cc1ae29b5c136995d7a2e684
DIST kinfocenter-5.24.3.tar.xz 718020 BLAKE2B 902aef9aa6e5ae31750fb5c61b73acb694b9081580daf15c8d26310797393e54440a0a194f7a9610639c9675f13d221e9c2c99d35047070500bf5cc89989dec2 SHA512 3cf295e3e09ffdd8b28cdae0966edca022bb7aa3ac0a55e8d93f104b3d189aa633bd19da11a056c7081a88901512c534853dbd0d617f19d1bb2c05d38ca6e535
+DIST kinfocenter-5.24.4.tar.xz 719404 BLAKE2B fb79a2c3ab6b6a7d7411a3c601b5e7e32b9c09e153baf15a76ff562570016b8d981f717f1866b5e23293537f85bc79ba335291751be7460dc0ed1700291739a3 SHA512 91fffdeb61e2dc67ab2abee6b1f0db9e7a9dcbd71005f27d644d654dbcd806e60fb1a4a54530477fb9a1eb91cea006a05575c4dc3e9461e8b8f18830d957f187
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.24.4.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.24.4.ebuild
new file mode 100644
index 000000000000..ecad66875ea1
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.24.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.90.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="gles2-only usb"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ gles2-only? ( media-libs/mesa[gles2] )
+ usb? ( virtual/libusb:1 )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+ >=kde-plasma/systemsettings-${PVCUT}:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package usb USB1)
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "advanced CPU information module" sys-apps/util-linux
+ fi
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "PCI devices information module" sys-apps/pciutils
+ optfeature "X Server information module" x11-apps/xdpyinfo
+ ecm_pkg_postinst
+}