summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-19 14:17:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-19 14:17:39 +0100
commite5b6f1e7918fa647bd5e182c7ffaed43785b5ed5 (patch)
tree05955d3b163be1bb5f5042438af1a57e0fda24c7 /kde-plasma/kscreenlocker
parentapp-misc/ca-certificates: fix double prefix (diff)
downloadgentoo-e5b6f1e7918fa647bd5e182c7ffaed43785b5ed5.tar.gz
gentoo-e5b6f1e7918fa647bd5e182c7ffaed43785b5ed5.tar.bz2
gentoo-e5b6f1e7918fa647bd5e182c7ffaed43785b5ed5.zip
kde-plasma: Add KDE Plasma 5.15.1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-plasma/kscreenlocker')
-rw-r--r--kde-plasma/kscreenlocker/Manifest1
-rw-r--r--kde-plasma/kscreenlocker/kscreenlocker-5.15.1.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/kde-plasma/kscreenlocker/Manifest b/kde-plasma/kscreenlocker/Manifest
index 19ead163a9f2..80afce453b09 100644
--- a/kde-plasma/kscreenlocker/Manifest
+++ b/kde-plasma/kscreenlocker/Manifest
@@ -1,2 +1,3 @@
DIST kscreenlocker-5.14.5.tar.xz 122232 BLAKE2B 652d8f2981231278d8890d2599466a86ca8530c44a2b6379631d575c457a573031672529313921fd87fbef6859302d8364ebf4769430941326e9c2ecc0d5196e SHA512 49348f137645333484be93922ec167403c74fce751294dbd02ffeedde6279ff0a0db8abc12153541612d4aeb6d6ed646b7f5ab22b78a8b80ae5eb37fa16f0e1d
DIST kscreenlocker-5.15.0.tar.xz 122200 BLAKE2B d88f8ce053cbbdf3fe5670e5c96621a48fd1e1001634bf6da264212b1bea8926d9c35602af7c13f7343520cae06b015f0d28c5c146da094a49f9ad018e71968a SHA512 6f6aa2f2146ef6d3959df430f79342d8354e61c2dac923243115a1178fdf3e8012af180030a65998473c41364ac74f2a69a3710f35211b79eb807b67eee61bd7
+DIST kscreenlocker-5.15.1.tar.xz 122740 BLAKE2B 313697c2c0c4d14195c42ad655162963e90f93c0723f19c09116d0e181817ca8b179c11b296c685bb5669fb7c82188176ccabc516b5c874bf1fd263e448b69a3 SHA512 006b1bff75abe0bae6c98e448d85fd1b5a8f5e0dd2eb53a2f6a51c6e9abc69feb9fe27480ec0e9cc43a0f9b1cd4fb28da1c988ba35ef6dec57f7fd571384ccff
diff --git a/kde-plasma/kscreenlocker/kscreenlocker-5.15.1.ebuild b/kde-plasma/kscreenlocker/kscreenlocker-5.15.1.ebuild
new file mode 100644
index 000000000000..7c403e5a5574
--- /dev/null
+++ b/kde-plasma/kscreenlocker/kscreenlocker-5.15.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5 pam
+
+DESCRIPTION="Library and components for secure lock screen architecture"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="consolekit +pam seccomp"
+
+REQUIRED_USE="seccomp? ( pam )"
+
+RDEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kidletime)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ dev-libs/wayland
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ consolekit? ( sys-auth/consolekit )
+ pam? ( virtual/pam )
+ seccomp? ( sys-libs/libseccomp )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+PDEPEND="
+ $(add_plasma_dep kde-cli-tools)
+"
+
+RESTRICT+=" test"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if ! use test; then
+ sed -e "/add_subdirectory(autotests)/ s/^/#/" \
+ -i greeter/CMakeLists.txt || die
+ fi
+}
+
+src_test() {
+ # requires running environment
+ local myctestargs=(
+ -E x11LockerTest
+ )
+ kde5_src_test
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package consolekit loginctl)
+ -DPAM_REQUIRED=$(usex pam)
+ $(cmake-utils_use_find_package pam PAM)
+ $(cmake-utils_use_find_package seccomp Seccomp)
+ )
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ use pam && newpamd "${FILESDIR}/kde.pam" kde
+ use pam && newpamd "${FILESDIR}/kde-np.pam" kde-np
+
+ if ! use pam; then
+ chown root "${ED}"/usr/$(get_libdir)/libexec/kcheckpass || die
+ chmod +s "${ED}"/usr/$(get_libdir)/libexec/kcheckpass || die
+ fi
+}