summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-07-24 13:54:16 +0200
committerJohannes Huber <johu@gentoo.org>2016-07-24 13:58:15 +0200
commit7da846b366215e5d5902a80b583bd30e5cf46559 (patch)
treef1679f526715b99099186f1f5f44f81d64893de7 /kde-plasma/ksshaskpass/ksshaskpass-0.5.3-r1.ebuild
parentx11-misc/xsnow: EAPI update. (diff)
downloadgentoo-7da846b366215e5d5902a80b583bd30e5cf46559.tar.gz
gentoo-7da846b366215e5d5902a80b583bd30e5cf46559.tar.bz2
gentoo-7da846b366215e5d5902a80b583bd30e5cf46559.zip
net-misc/ksshaskpass -> kde-plasma/ksshaskpass
Diffstat (limited to 'kde-plasma/ksshaskpass/ksshaskpass-0.5.3-r1.ebuild')
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-0.5.3-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-0.5.3-r1.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..64d11430b4d5
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-0.5.3-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="http://www.kde-apps.org/content/show.php?content=50971&forumpage=0"
+SRC_URI="http://www.kde-apps.org/CONTENT/content-files/50971-${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+SLOT="4"
+IUSE="debug"
+
+RDEPEND="net-misc/openssh"
+
+CFG="ksshaskpass.sh"
+
+src_prepare() {
+ STARTUPDIR=/etc/kde/startup
+ SHUTDOWNDIR=/etc/kde/shutdown
+
+ kde4-base_src_prepare
+}
+
+src_install() {
+ kde4-base_src_install
+
+ cat <<-EOF > "${T}/${CFG}"
+export SSH_ASKPASS="${PREFIX}/bin/ksshaskpass"
+EOF
+ insinto "${STARTUPDIR}"
+ doins "${T}/${CFG}"
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ elog
+ elog "In order to have ksshagent start at kde startup,"
+ elog "edit ${STARTUPDIR}/agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in ${SHUTDOWNDIR}/agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${P} has been installed as your default askpass application in KDE4 session."
+ elog "If it's not desired, point the one you want to use in ${STARTUPDIR}/${CFG}"
+ elog
+}