summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-23 18:51:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-23 18:54:05 +0200
commit56148d2ee3e83c17a64f8672d32143bcb2f56e02 (patch)
tree5a36a0e471249e90170111f32bfdb74897ff64b0 /kde-plasma/ksshaskpass/ksshaskpass-5.14.2.ebuild
parentwww-client/firefox: update patch URL (diff)
downloadgentoo-56148d2ee3e83c17a64f8672d32143bcb2f56e02.tar.gz
gentoo-56148d2ee3e83c17a64f8672d32143bcb2f56e02.tar.bz2
gentoo-56148d2ee3e83c17a64f8672d32143bcb2f56e02.zip
kde-plasma: Add KDE Plasma 5.14.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'kde-plasma/ksshaskpass/ksshaskpass-5.14.2.ebuild')
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.14.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.14.2.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.14.2.ebuild
new file mode 100644
index 000000000000..058e2fe8d646
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.14.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="
+ ${DEPEND}
+ !kde-plasma/ksshaskpass:4
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}