summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-11-01 20:34:20 +0100
committerJohannes Huber <johu@gentoo.org>2016-11-01 21:37:31 +0100
commit5c5502ad72e4d52a512eca3d9ddf38467d6c1b00 (patch)
tree225c22c90f772bf2e8b9a4e1dade50cf19176f23 /kde-plasma/ksshaskpass/ksshaskpass-5.8.3.ebuild
parentdev-python/cryptography: add pytz dependency for tests (fixes bug 595270) (diff)
downloadgentoo-5c5502ad72e4d52a512eca3d9ddf38467d6c1b00.tar.gz
gentoo-5c5502ad72e4d52a512eca3d9ddf38467d6c1b00.tar.bz2
gentoo-5c5502ad72e4d52a512eca3d9ddf38467d6c1b00.zip
kde-plasma: Version bump KDE Plasma 5.8.3
Package-Manager: portage-2.3.2
Diffstat (limited to 'kde-plasma/ksshaskpass/ksshaskpass-5.8.3.ebuild')
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.8.3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.8.3.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.8.3.ebuild
new file mode 100644
index 000000000000..4fed5b5ec2c5
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.8.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/ksshaskpass"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="
+ ${DEPEND}
+ !kde-plasma/ksshaskpass:4
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}