summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-08 13:40:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-08 14:32:55 +0100
commit5e0f583660d70d633152b9639af6b52e6f690090 (patch)
tree361e6c35245cbfb031ee399a9d3d441768480d8e /kde-plasma/ksshaskpass
parentdev-lang/ruby: Added sys-libs/readline to RDEPEND. (diff)
downloadgentoo-5e0f583660d70d633152b9639af6b52e6f690090.tar.gz
gentoo-5e0f583660d70d633152b9639af6b52e6f690090.tar.bz2
gentoo-5e0f583660d70d633152b9639af6b52e6f690090.zip
kde-plasma: Add KDE Plasma 5.14.5
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.14.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 6fd8b73bab86..88094efeec33 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.14.3.tar.xz 21400 BLAKE2B 86606d6de13b785a5b78cbd08e588d88057818b91799aedecee5514e88a34c4cfc4b1cc0910d0ff145963aa74f979f80d17146342f5fc4e64a794cb85f701a0a SHA512 d4aa1870c9e484e8e855d701585076e6ff25af6647e3c97075b3296a4a7603b32833e147dcd8c42073c67ffa9fff77b2f65697bb5885529ce0fd17e29dbe8e76
DIST ksshaskpass-5.14.4.tar.xz 21304 BLAKE2B 43e6130dc10da10dc90e6408cc66f7a252df3d68544151b787c4818e587748a9f513616c614d167e3f11001c7125deab2376b5e3d346d7322cf8e7bb93c4aca1 SHA512 e838243f8f9186db81992b939dc300d52f4462b2038fecb85cdee5b107e53bff19c0ae359a18340215516a2c663dda02c3b11a7e0e0a839b4453b173be97969a
+DIST ksshaskpass-5.14.5.tar.xz 21332 BLAKE2B a29b1fc2802925759eaf1b9ff8dec7dd0dddcf67b2093fd6b8a9bccb112264a9f01cbc8b42e707b9782cd3efe9d272ae9ca573e3e084f5a3dfe632d88be52104 SHA512 5517193df92ad868d06bcc8f353bfd38932d0a96d98e6af38d3714478233ea91771cbb7b075e76c133d595812643a0e2fea6a6086be94845a252c215b243b37f
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.14.5.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.14.5.ebuild
new file mode 100644
index 000000000000..ebf909cacf25
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.14.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="
+ ${DEPEND}
+ !kde-plasma/ksshaskpass:4
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}