summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-13 11:33:56 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-14 12:26:13 +0100
commitb1e3be89db6fea433d2338018d96fe2362818a30 (patch)
tree36d7db22df0b21bf85d8ed53202ad53f21dfb3ab /kde-plasma/ksshaskpass
parentkde-plasma/kscreenlocker: 5.27.0 version bump (diff)
downloadgentoo-b1e3be89db6fea433d2338018d96fe2362818a30.tar.gz
gentoo-b1e3be89db6fea433d2338018d96fe2362818a30.tar.bz2
gentoo-b1e3be89db6fea433d2338018d96fe2362818a30.zip
kde-plasma/ksshaskpass: 5.27.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.27.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 1278039c6ca1..7d88c645d6f5 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.26.5.tar.xz 27580 BLAKE2B e5fed3921804b91f5f7e9a38a327a4b03cbf1fae2a6ba7a4ce123171ea70122f0c86a20f8c719c0459b5084098f042b731a912b9c0bd9979b80793043796184d SHA512 a1e50379415d006f5a2ca8292147e3bf33cb7588a6c03d5ed6dc11c0e77a3c2abf93e950f61391f464a9d17389b75dadc6e16721ec9cad7e71266ca7c0496bfd
DIST ksshaskpass-5.26.90.tar.xz 27744 BLAKE2B d50c4adf7fbc2d66b66281827422358a3d09710cbc4650f54679662e263cf4144406e96bdaf68e34cead0936dfe627dc5e8f6bff4c193a53a2af745d41c71827 SHA512 ee14307aa0342d016b4c2732591f96f2a0065ae60bc951a5fed36537baa1c08c7fc75dbd63bfc942f98505c8e26c5c9644fa82fdeecc5bd5a942314320fe5322
+DIST ksshaskpass-5.27.0.tar.xz 27752 BLAKE2B 1d81f7d6302b59551351e0cd49c01b49fd77563207606248832495afdd1132b453cc45f56262aa24f90fb8d1c4eb6eeb84565717a22482dc8688f50d2394f109 SHA512 2311d43f7dbd3187ae5406a8a0da522bfdcf438bfcec5748f5b3ca8f98d6caa6ecd23cb081bcc0a3ae7b2e9e182d1bba9df7a558c00f914cac5dd2527782933a
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.27.0.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.27.0.ebuild
new file mode 100644
index 000000000000..406a6e3e3596
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.27.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.102.0
+QTMIN=5.15.7
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}