summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-19 10:42:28 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-19 11:46:14 +0100
commitcdc15007a558479a7f46bfb2cb2429ead498306d (patch)
tree0682eddb09b25bd2408d2c476eba74f7c9ebcbd8 /kde-plasma/ksshaskpass
parentdev-libs/kuserfeedback: Restore empty line gone during conflict res. (diff)
downloadgentoo-cdc15007a558479a7f46bfb2cb2429ead498306d.tar.gz
gentoo-cdc15007a558479a7f46bfb2cb2429ead498306d.tar.bz2
gentoo-cdc15007a558479a7f46bfb2cb2429ead498306d.zip
kde-plasma: Add KDE Plasma 5.18.1
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.18.1.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index df6008359a98..9d3c8a23883d 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.17.5.tar.xz 21372 BLAKE2B 134a533570b75d66cff195819d41b782b67e0f308d6b36efdd7ca223cfb8994baf29506e3cfc34c6786d35eedf792ed6519b40b0f39360468465c76a197c8362 SHA512 c3a6d5b914c13cdd2ca94a237168702729755ba51e036bef1fb5f09f9e7d1c01c176ba14f225c5ae3781434e8fcc047dd250f9da8d3704da09e9712819a5948a
DIST ksshaskpass-5.18.0.tar.xz 22192 BLAKE2B 57205ff7049e3ff62a66199687fb0cb7bff6f95e80f499d6705483d2d593b2693acae2a8a0bc735185166a148db151891f42656a7fd010dd9c945d0bad4f7bdf SHA512 b16c56845576c1d0c19deabd2a826d631eebef9307e93aded4f8b3f8bbeb02992a3d5e29278f1c2eeecf40c59c5e31612f2bf5125e7b5b65d04db3fb1d1abb94
+DIST ksshaskpass-5.18.1.tar.xz 22232 BLAKE2B eff3983e0878576ccdd9ca1c8411fb1b361b8282bbd86f85085eff288a81bd18dae4918a939ef60f5b12ee4f51e815044f651a3a64c06f1a916181ccd63cd29a SHA512 c905849ee3f957f6767187109abbac29c8036c90fa54b7fd13a3f9c1bdd9f869f93d3ed06fa9b227219518eb38a6b3145d1c4cf3cdf59e5477db2acc7b9cd0ff
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.18.1.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.18.1.ebuild
new file mode 100644
index 000000000000..c70895fa5a1d
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.18.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.66.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ ecm_pkg_setup
+
+ local srcfile=/etc/plasma/startup/05-ksshaskpass.sh
+ local newfile=/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh
+ if [[ -f "${EROOT}"${srcfile} ]]; then
+ local md5=$(md5sum "${EROOT}"${srcfile})
+ if [[ ${md5%% *} != 615ae8f5b0090ff7f51d0edee7885d55 ]]; then
+ elog "Existing modified "${EPREFIX}"${srcfile} detected."
+ elog "Copying to "${EPREFIX}"${newfile}..."
+ cp -v "${EROOT}"${srcfile} "${T}"/ || die
+ fi
+ fi
+}
+
+src_prepare() {
+ ecm_src_prepare
+ if [[ ! -f "${T}"/05-ksshaskpass.sh ]]; then
+ cp "${FILESDIR}"/05-ksshaskpass.sh "${T}"/ || die
+ fi
+}
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 script
+ if [[ -e "${EROOT}"/etc/plasma/startup/05-ksshaskpass.sh ]]; then
+ rm "${EROOT}"/etc/plasma/startup/05-ksshaskpass.sh || die
+ elog "Removed obsolete ${EPREFIX}/etc/plasma/startup/05-ksshaskpass.sh"
+ fi
+}