summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-11-04 12:48:33 +0100
committerJohannes Huber <johu@gentoo.org>2016-11-04 12:49:59 +0100
commit141e69448a61fd13655cdd2936806509de135513 (patch)
tree52348be1bdcd791154bc1d8c411cc768d1aedf1b /kde-plasma/ksysguard/ksysguard-4.11.22.ebuild
parentsys-kernel/vanilla-sources: Automated version bump to {4.4.30,4.8.6} - remove... (diff)
downloadgentoo-141e69448a61fd13655cdd2936806509de135513.tar.gz
gentoo-141e69448a61fd13655cdd2936806509de135513.tar.bz2
gentoo-141e69448a61fd13655cdd2936806509de135513.zip
kde-base/ksysguard -> kde-plasma/ksysguard
Diffstat (limited to 'kde-plasma/ksysguard/ksysguard-4.11.22.ebuild')
-rw-r--r--kde-plasma/ksysguard/ksysguard-4.11.22.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/ksysguard-4.11.22.ebuild b/kde-plasma/ksysguard/ksysguard-4.11.22.ebuild
new file mode 100644
index 000000000000..6e8c1163db82
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-4.11.22.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-workspace"
+CPPUNIT_REQUIRED="optional"
+VIRTUALX_REQUIRED="test"
+WEBKIT_REQUIRED="always"
+inherit kde4-meta
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+HOMEPAGE+=" https://userbase.kde.org/KSysGuard"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+IUSE="debug lm_sensors test"
+
+DEPEND="
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXres
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+# bug 393091
+
+KMEXTRA="
+ libs/ksysguard/
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with lm_sensors Sensors)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ ewarn "Note that ksysguard has powerful features; one of these is the executing of arbitrary"
+ ewarn "programs with elevated privileges (as data sources). So be careful opening worksheets"
+ ewarn "from untrusted sources!"
+}