summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-13 19:57:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-13 20:43:12 +0100
commitd4fe789db1d07b9069fafd3728f09cfc325800d6 (patch)
treecaf29d096849a0b777c8c3a2383fc0666c6d11eb /kde-plasma/ksysguard/ksysguard-5.12.1.ebuild
parentkde-frameworks/kholidays: Restore accidentally lost ~arm,~arm64 keywords (diff)
downloadgentoo-d4fe789db1d07b9069fafd3728f09cfc325800d6.tar.gz
gentoo-d4fe789db1d07b9069fafd3728f09cfc325800d6.tar.bz2
gentoo-d4fe789db1d07b9069fafd3728f09cfc325800d6.zip
kde-plasma: Add KDE Plasma 5.12.1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'kde-plasma/ksysguard/ksysguard-5.12.1.ebuild')
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.12.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/ksysguard-5.12.1.ebuild b/kde-plasma/ksysguard/ksysguard-5.12.1.ebuild
new file mode 100644
index 000000000000..5e2260a85627
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.12.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+RDEPEND="${DEPEND}
+ !kde-plasma/ksysguard:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}