summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-03-28 22:46:29 +0200
committerJohannes Huber <johu@gentoo.org>2018-03-28 23:01:25 +0200
commit7b987bb059c77d82ef9b24b535e8a09430b9ac35 (patch)
tree202828e2af1320fe8f4218cb1aea662295840a78 /kde-plasma/ksysguard
parentmedia-libs/openjpeg: Fix 2.3.0 USE=static-libs compile (diff)
downloadgentoo-7b987bb059c77d82ef9b24b535e8a09430b9ac35.tar.gz
gentoo-7b987bb059c77d82ef9b24b535e8a09430b9ac35.tar.bz2
gentoo-7b987bb059c77d82ef9b24b535e8a09430b9ac35.zip
kde-plasma: Version bump KDE Plasma 5.12.4
Package-Manager: Portage-2.3.26, Repoman-2.3.7
Diffstat (limited to 'kde-plasma/ksysguard')
-rw-r--r--kde-plasma/ksysguard/Manifest1
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.12.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/Manifest b/kde-plasma/ksysguard/Manifest
index 4601aa68e496..73beba7c946a 100644
--- a/kde-plasma/ksysguard/Manifest
+++ b/kde-plasma/ksysguard/Manifest
@@ -1,2 +1,3 @@
DIST ksysguard-5.11.5.tar.xz 502228 BLAKE2B 49e82c26ea1c032e8e036e509c6a46c5da409f4092679a623bc26342f34ffa90d96306fb5638b1fe5a4edafe6f48af6ee12876286788b11145c00c1a32765edb SHA512 62af21b0d911abac5b66ccddeb0180c08199c0cfd8807d461fcfe444105ce7912efb5b8286e7f4955e97cb537edc32f046d646e82ecfc2d61ec39b2a53ed4d93
DIST ksysguard-5.12.3.tar.xz 486832 BLAKE2B a066fab22cd2ca648af04ffdf69366fbc2fc1cde52d2bd6a321ee5cd160a6fc7ea84c72950a66f96299bb64d3b90bdfa3c0220e65f9ab596779128c8a02be1fc SHA512 2d727136554242eca2428198f4b08b6ce6d062a4278a053502489303be6950a5efdf2f6852cb56105cd1d1dcb9ea1401c028c0654b2dda9eb898ba7cd8ed5f4e
+DIST ksysguard-5.12.4.tar.xz 486016 BLAKE2B b99d939431ccaedff7484734f85e05840c3ca6071efe38d4f23ad0f8cb43a9c7a18ff28cc3d34b46cbbb7196ce7fcc88130d9d974e6037a08aab36b46d4f3d4f SHA512 4608672cfdc9c5b6bb36194ba33e4db579e8c9fcaab421ef034ea8e5cc104a54091cefbe84059f3efb9972929f6c0a7878a55b32ef9c83d858ca1e880f325413
diff --git a/kde-plasma/ksysguard/ksysguard-5.12.4.ebuild b/kde-plasma/ksysguard/ksysguard-5.12.4.ebuild
new file mode 100644
index 000000000000..5e2260a85627
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.12.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+RDEPEND="${DEPEND}
+ !kde-plasma/ksysguard:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}