summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-03 12:51:13 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-03 12:55:08 +0200
commita76abf47ec66858dde347079afa915589b44b7bb (patch)
tree9681d4d56bc37c200495f2716d28b40eeee25ffb /kde-plasma/ksysguard
parentprofiles: arm: Add plasma-meta[browser-integration] to p.use.mask (diff)
downloadgentoo-a76abf47ec66858dde347079afa915589b44b7bb.tar.gz
gentoo-a76abf47ec66858dde347079afa915589b44b7bb.tar.bz2
gentoo-a76abf47ec66858dde347079afa915589b44b7bb.zip
kde-plasma: Add KDE Plasma 5.13.2
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'kde-plasma/ksysguard')
-rw-r--r--kde-plasma/ksysguard/Manifest1
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.13.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/Manifest b/kde-plasma/ksysguard/Manifest
index 44672f888c89..30c0565be958 100644
--- a/kde-plasma/ksysguard/Manifest
+++ b/kde-plasma/ksysguard/Manifest
@@ -1,2 +1,3 @@
DIST ksysguard-5.12.5.tar.xz 486676 BLAKE2B 4c706d719920beaf1ec831d23d918a254e01281e89232b1b36e9ca0f5a3134b3b688f7b37af3f41836808a3a3d8ac8052da65df80198ab8ad20fcfa288e868db SHA512 02f5b64a39e395869479ab93ef683136b7017dfb51e55dc03206641bd46052e656547244fc2b6cd86902d5a4f08a5a8fd7d1d5ba0fed73c765a2cfbc39f4bd32
DIST ksysguard-5.12.6.tar.xz 490700 BLAKE2B 983efe089236f929f0eaef8c43c17a57223c1710d153240b10a76cdacbda974b4c135b3002a89edc72be605fcf07a61e02de9c00aa7291d84777b71190a2e86b SHA512 ca0d21e6ed8fc8b042c6a0fbbfd0fa57811bf0e90da323df32c7905f8ce96155b67916d3038f8a993ab8e12383c1a3131d5d3bfb028cc374ea46129046f5ad81
+DIST ksysguard-5.13.2.tar.xz 492228 BLAKE2B f8f8fdc472b2809611d4681a413785ce3a8cda192474a7057d2f08a08a1237e4bd9fa6540cf7df4fd3dcc1f917f41acc1a7ab8db479b75663d504b90f4cbd258 SHA512 1d4f77b8ab0b3de373e121b5c89d4ad0bf01833ebc42d25e417f5f42ce4173f190c814b13332f0519efeb0daf526096621734e0dae36b00759e88da7a8b99020
diff --git a/kde-plasma/ksysguard/ksysguard-5.13.2.ebuild b/kde-plasma/ksysguard/ksysguard-5.13.2.ebuild
new file mode 100644
index 000000000000..5e2260a85627
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.13.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+RDEPEND="${DEPEND}
+ !kde-plasma/ksysguard:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}