summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-16 15:50:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-16 16:10:11 +0200
commit524f23aec3415a004813ab5ddbc05980d2950a61 (patch)
tree86556bbe235a2f41f1f389d5d8812abbcba4d1cb /kde-plasma/kwallet-pam/kwallet-pam-5.14.1.ebuild
parentapp-backup/btrbk: 0.27.0 version bump (diff)
downloadgentoo-524f23aec3415a004813ab5ddbc05980d2950a61.tar.gz
gentoo-524f23aec3415a004813ab5ddbc05980d2950a61.tar.bz2
gentoo-524f23aec3415a004813ab5ddbc05980d2950a61.zip
kde-plasma: Add KDE Plasma 5.14.1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-plasma/kwallet-pam/kwallet-pam-5.14.1.ebuild')
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.14.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.14.1.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.14.1.ebuild
new file mode 100644
index 000000000000..810eaac889ae
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.14.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KWallet PAM module to not enter password again"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ virtual/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ -DKWALLET4=0
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}