summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-11 13:55:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-11 15:21:12 +0100
commit8c54b14a9c55fadb89bba7109a7b86778b764c52 (patch)
tree821e228ea106428f8962787c68d38a03e79be26a /kde-plasma/kwallet-pam
parentkde-plasma/ksysguard: 5.20.3 version bump (diff)
downloadgentoo-8c54b14a9c55fadb89bba7109a7b86778b764c52.tar.gz
gentoo-8c54b14a9c55fadb89bba7109a7b86778b764c52.tar.bz2
gentoo-8c54b14a9c55fadb89bba7109a7b86778b764c52.zip
kde-plasma/kwallet-pam: 5.20.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.20.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 1ffa9cfc9a85..54f8f6d8ea4f 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.19.5.tar.xz 19932 BLAKE2B 28d8419f500c163ba15a79cc994af70b723dff24fa8c32e899bd856766290f20d09e3ee98e164d55596d1b97137e92096f9c2c3cf2386bb700aa0b7bcfed1c39 SHA512 3fe30f979f6ee838b073b7afdb406068f90529fbbac3513d65145f6a46ab8ba0b61ba11a3e9192c60b1ddd50e9af448c1298725fc01dca483b40a8030053095d
DIST kwallet-pam-5.20.2.tar.xz 19820 BLAKE2B 95542f6f4cd7dd656f67edfc49545db92c3e8bb2d74a934570684cfdb9e0588e90ad3c9dc9113ea66c2f1ab7dd8abdd9b25e93534b72f83cc441ca86af32b67e SHA512 3c1c75e9ab61bb2497272a361b06b4d163c762b7ad5e89790e00ce7d73ddfe6bedf5eb035930cc0f6627450c20726aae1fa2ffd18c42f14cb59239b504dea797
+DIST kwallet-pam-5.20.3.tar.xz 19868 BLAKE2B 0c774b155f1d6f3b871b5c5d0dce5a67a53ff46a1b5b0e86bb60e0301e2701cbbcc1d0f145d6ec01172495c61d976310323d5edd3c80028b93b34e4608603b4a SHA512 566e6c7cb3581fc5ea05fe35163af3e1f76d8baa74d30c3ca996c5b265645168589e52f7fe6bb89675f7c1252362af19bfe469fc987f0f8d843f0a897fdf0b13
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.20.3.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.20.3.ebuild
new file mode 100644
index 000000000000..121f17823eb9
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.20.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.74.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}