summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-06-27 13:33:43 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-06-27 18:42:19 +0200
commit713bb1df50f36712885d5dcb635b4c959b389ac5 (patch)
treea5ce482aa616a94c73f69aaed37aef073dff4dce /kde-plasma/kwin/kwin-5.10.3.ebuild
parentwww-servers/nginx: Bump to v1.13.2 mainline (diff)
downloadgentoo-713bb1df50f36712885d5dcb635b4c959b389ac5.tar.gz
gentoo-713bb1df50f36712885d5dcb635b4c959b389ac5.tar.bz2
gentoo-713bb1df50f36712885d5dcb635b4c959b389ac5.zip
kde-plasma: KDE Plasma 5.10.3 version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'kde-plasma/kwin/kwin-5.10.3.ebuild')
-rw-r--r--kde-plasma/kwin/kwin-5.10.3.ebuild95
1 files changed, 95 insertions, 0 deletions
diff --git a/kde-plasma/kwin/kwin-5.10.3.ebuild b/kde-plasma/kwin/kwin-5.10.3.ebuild
new file mode 100644
index 000000000000..30a4b71b6a23
--- /dev/null
+++ b/kde-plasma/kwin/kwin-5.10.3.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE window manager"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gles2 multimedia"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kactivities)
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kidletime)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem X)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep plasma)
+ $(add_plasma_dep breeze)
+ $(add_plasma_dep kdecoration)
+ $(add_plasma_dep kscreenlocker)
+ $(add_qt_dep qtcore)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui 'gles2=')
+ $(add_qt_dep qtscript)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ >=dev-libs/libinput-1.5
+ >=dev-libs/wayland-1.2
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libepoxy
+ media-libs/mesa[egl,gbm,gles2?,wayland]
+ virtual/libudev:=
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libdrm
+ >=x11-libs/libxcb-1.10
+ >=x11-libs/libxkbcommon-0.7.0
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-keysyms
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ multimedia? (
+ || (
+ $(add_qt_dep qtmultimedia 'gstreamer,qml')
+ $(add_qt_dep qtmultimedia 'gstreamer010,qml')
+ )
+ )
+ !<kde-apps/kdeartwork-meta-15.08.3-r1:4
+ !kde-plasma/kwin:4
+ !kde-plasma/systemsettings:4
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_qt_dep designer)
+ $(add_qt_dep qtconcurrent)
+ x11-proto/xproto
+ test? ( x11-libs/xcb-util-wm )
+"
+
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${PN}-5.8.7-glibc-sysmacros.patch" )
+
+src_prepare() {
+ kde5_src_prepare
+ use multimedia || eapply "${FILESDIR}/${PN}-gstreamer-optional.patch"
+}