summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-05 20:20:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-09 21:00:15 +0200
commit498c8adad07151902c362e83286b959170e6709c (patch)
tree69dd95206c1da64aa491f97af0d20aca6cadd0d9 /kde-plasma/kwin
parentkde-plasma/kwayland-integration: drop 5.18.5* (diff)
downloadgentoo-498c8adad07151902c362e83286b959170e6709c.tar.gz
gentoo-498c8adad07151902c362e83286b959170e6709c.tar.bz2
gentoo-498c8adad07151902c362e83286b959170e6709c.zip
kde-plasma/kwin: drop 5.18.5*
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwin')
-rw-r--r--kde-plasma/kwin/Manifest1
-rw-r--r--kde-plasma/kwin/files/kwin-5.18.5-dont-exec-QDialog.patch149
-rw-r--r--kde-plasma/kwin/files/kwin-5.18.5-mesa-21.patch193
-rw-r--r--kde-plasma/kwin/files/kwin-5.18.5-qt-5.15.patch39
-rw-r--r--kde-plasma/kwin/files/kwin-5.18.5-wayland-lockscreen-greeter.patch73
-rw-r--r--kde-plasma/kwin/kwin-5.18.5-r1.ebuild117
-rw-r--r--kde-plasma/kwin/kwin-5.18.5-r3.ebuild119
7 files changed, 0 insertions, 691 deletions
diff --git a/kde-plasma/kwin/Manifest b/kde-plasma/kwin/Manifest
index 2418ba7bb6fa..9d92c9f94aa6 100644
--- a/kde-plasma/kwin/Manifest
+++ b/kde-plasma/kwin/Manifest
@@ -1,2 +1 @@
-DIST kwin-5.18.5.tar.xz 6274772 BLAKE2B 1614515df60667fb6e8f45302db13dc43ca896c7266c2e2846fd1a1da75b4054cbe14a27b8b3f7d71ae6398e2cf4d9e8e2a68af1c1fa6809a271c5b29574a023 SHA512 b703891824ec31e8ae29df27a11499579ab95789a838e893d5904e40aeba27b0ddc04836038d5b4c062d75ceed277d07e67eeb1b4e957ccf414f03786037d562
DIST kwin-5.19.5.tar.xz 6260188 BLAKE2B bcf3c8afc00af0df8cddeb49396bd23df6178e379ac4c3ba3c547a2c602d309202a72136b69b83f729434fc5691ba24699cf3f44d47b2c033623bca5d551bdb1 SHA512 97ad0096066d99b4bba3089416a6d3744b6f83d82a004caa8762b420cad34cac4221b3535678d4c6f1bcb43c4d97db56be5ac68c4ac501dc168f4472a6c0dad5
diff --git a/kde-plasma/kwin/files/kwin-5.18.5-dont-exec-QDialog.patch b/kde-plasma/kwin/files/kwin-5.18.5-dont-exec-QDialog.patch
deleted file mode 100644
index df65c32fb13a..000000000000
--- a/kde-plasma/kwin/files/kwin-5.18.5-dont-exec-QDialog.patch
+++ /dev/null
@@ -1,149 +0,0 @@
-From 5ea54eda5d1f91428933d338ea8b950aea86d43a Mon Sep 17 00:00:00 2001
-From: Kai Uwe Broulik <kde@privat.broulik.de>
-Date: Wed, 6 May 2020 15:15:03 +0200
-Subject: [kcmkwin/kwindecoration] Don't exec() QDialog
-
-Using nested event loops with QML is always troublesome.
-
-BUG: 421053
-FIXED-IN: 5.18.6
-
-Differential Revision: https://phabricator.kde.org/D29473
----
- .../declarative-plugin/previewbridge.cpp | 32 +++++++++++++++-------
- .../declarative-plugin/previewbridge.h | 4 ++-
- .../kwindecoration/package/contents/ui/Themes.qml | 3 +-
- 3 files changed, 27 insertions(+), 12 deletions(-)
-
-diff --git a/kcmkwin/kwindecoration/declarative-plugin/previewbridge.cpp b/kcmkwin/kwindecoration/declarative-plugin/previewbridge.cpp
-index bad4cc1..83a9bd9 100644
---- a/kcmkwin/kwindecoration/declarative-plugin/previewbridge.cpp
-+++ b/kcmkwin/kwindecoration/declarative-plugin/previewbridge.cpp
-@@ -36,7 +36,11 @@
- #include <QDialog>
- #include <QDialogButtonBox>
- #include <QPushButton>
-+#include <QQuickItem>
-+#include <QQuickRenderControl>
-+#include <QQuickWindow>
- #include <QVBoxLayout>
-+#include <QWindow>
-
- namespace KDecoration2
- {
-@@ -173,15 +177,16 @@ DecorationButton *PreviewBridge::createButton(KDecoration2::Decoration *decorati
- return m_factory->create<KDecoration2::DecorationButton>(QStringLiteral("button"), parent, QVariantList({QVariant::fromValue(type), QVariant::fromValue(decoration)}));
- }
-
--void PreviewBridge::configure()
-+void PreviewBridge::configure(QQuickItem *ctx)
- {
- if (!m_valid) {
- return;
- }
- //setup the UI
-- QDialog dialog;
-+ QDialog *dialog = new QDialog();
-+ dialog->setAttribute(Qt::WA_DeleteOnClose);
- if (m_lastCreatedClient) {
-- dialog.setWindowTitle(m_lastCreatedClient->caption());
-+ dialog->setWindowTitle(m_lastCreatedClient->caption());
- }
-
- // create the KCModule through the plugintrader
-@@ -189,7 +194,7 @@ void PreviewBridge::configure()
- if (!m_theme.isNull()) {
- args.insert(QStringLiteral("theme"), m_theme);
- }
-- KCModule *kcm = m_factory->create<KCModule>(QStringLiteral("kcmodule"), &dialog, QVariantList({args}));
-+ KCModule *kcm = m_factory->create<KCModule>(QStringLiteral("kcmodule"), dialog, QVariantList({args}));
- if (!kcm) {
- return;
- }
-@@ -205,28 +210,35 @@ void PreviewBridge::configure()
- QStringLiteral("reloadConfig"));
- QDBusConnection::sessionBus().send(message);
- };
-- connect(&dialog, &QDialog::accepted, this, save);
-+ connect(dialog, &QDialog::accepted, this, save);
-
- QDialogButtonBox *buttons = new QDialogButtonBox(QDialogButtonBox::Ok |
- QDialogButtonBox::Cancel |
- QDialogButtonBox::RestoreDefaults |
- QDialogButtonBox::Reset,
-- &dialog);
-+ dialog);
-
- QPushButton *reset = buttons->button(QDialogButtonBox::Reset);
- reset->setEnabled(false);
- // Here we connect our buttons with the dialog
-- connect(buttons, &QDialogButtonBox::accepted, &dialog, &QDialog::accept);
-- connect(buttons, &QDialogButtonBox::rejected, &dialog, &QDialog::reject);
-+ connect(buttons, &QDialogButtonBox::accepted, dialog, &QDialog::accept);
-+ connect(buttons, &QDialogButtonBox::rejected, dialog, &QDialog::reject);
- connect(reset, &QPushButton::clicked, kcm, &KCModule::load);
- auto changedSignal = static_cast<void(KCModule::*)(bool)>(&KCModule::changed);
- connect(kcm, changedSignal, reset, &QPushButton::setEnabled);
- connect(buttons->button(QDialogButtonBox::RestoreDefaults), &QPushButton::clicked, kcm, &KCModule::defaults);
-
-- QVBoxLayout *layout = new QVBoxLayout(&dialog);
-+ QVBoxLayout *layout = new QVBoxLayout(dialog);
- layout->addWidget(kcm);
- layout->addWidget(buttons);
-- dialog.exec();
-+
-+ if (ctx->window()) {
-+ dialog->winId(); // so it creates windowHandle
-+ dialog->windowHandle()->setTransientParent(QQuickRenderControl::renderWindowFor(ctx->window()));
-+ dialog->setModal(true);
-+ }
-+
-+ dialog->show();
- }
-
- BridgeItem::BridgeItem(QObject *parent)
-diff --git a/kcmkwin/kwindecoration/declarative-plugin/previewbridge.h b/kcmkwin/kwindecoration/declarative-plugin/previewbridge.h
-index 7e1d8f3..85fccbe 100644
---- a/kcmkwin/kwindecoration/declarative-plugin/previewbridge.h
-+++ b/kcmkwin/kwindecoration/declarative-plugin/previewbridge.h
-@@ -26,6 +26,8 @@
- #include <QList>
- #include <QPointer>
-
-+class QQuickItem;
-+
- class KPluginFactory;
-
- namespace KDecoration2
-@@ -70,7 +72,7 @@ public:
- KDecoration2::DecorationButton *createButton(KDecoration2::Decoration *decoration, KDecoration2::DecorationButtonType type, QObject *parent = nullptr);
-
- public Q_SLOTS:
-- void configure();
-+ void configure(QQuickItem *ctx);
-
- Q_SIGNALS:
- void pluginChanged();
-diff --git a/kcmkwin/kwindecoration/package/contents/ui/Themes.qml b/kcmkwin/kwindecoration/package/contents/ui/Themes.qml
-index 28e5899..1eeb4cd 100644
---- a/kcmkwin/kwindecoration/package/contents/ui/Themes.qml
-+++ b/kcmkwin/kwindecoration/package/contents/ui/Themes.qml
-@@ -40,6 +40,7 @@ KCM.GridView {
- view.implicitCellWidth: Kirigami.Units.gridUnit * 18
-
- view.delegate: KCM.GridDelegate {
-+ id: delegate
- text: model.display
-
- thumbnailAvailable: true
-@@ -101,7 +102,7 @@ KCM.GridView {
- onTriggered: {
- kcm.theme = index
- view.currentIndex = index
-- bridgeItem.bridge.configure()
-+ bridgeItem.bridge.configure(delegate)
- }
- }
- ]
---
-cgit v1.1
diff --git a/kde-plasma/kwin/files/kwin-5.18.5-mesa-21.patch b/kde-plasma/kwin/files/kwin-5.18.5-mesa-21.patch
deleted file mode 100644
index dc87b4045483..000000000000
--- a/kde-plasma/kwin/files/kwin-5.18.5-mesa-21.patch
+++ /dev/null
@@ -1,193 +0,0 @@
-From 2c76cc4784382b3df9b5413860d0793ea26cea31 Mon Sep 17 00:00:00 2001
-From: Vlad Zahorodnii <vlad.zahorodnii@kde.org>
-Date: Fri, 29 May 2020 16:01:27 +0300
-Subject: [wayland] Fix misuse of EGL/eglmesaext.h
-
-The recommended way to get all EGL extension defines is to include
-EGL/eglext.h. EGL/eglmesaext.h is a private header that compositors
-should not use.
-
-BUG: 422131
----
- .../scenes/opengl/abstract_egl_backend.cpp | 11 +---
- platformsupport/scenes/opengl/egl_dmabuf.cpp | 41 +-----------
- platformsupport/scenes/opengl/kwineglext.h | 76 ++++++++++++++++++++++
- 3 files changed, 78 insertions(+), 50 deletions(-)
- create mode 100644 platformsupport/scenes/opengl/kwineglext.h
-
-diff --git a/platformsupport/scenes/opengl/abstract_egl_backend.cpp b/platformsupport/scenes/opengl/abstract_egl_backend.cpp
-index 532ec27..e160ef3 100644
---- a/platformsupport/scenes/opengl/abstract_egl_backend.cpp
-+++ b/platformsupport/scenes/opengl/abstract_egl_backend.cpp
-@@ -19,6 +19,7 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
- *********************************************************************/
- #include "abstract_egl_backend.h"
- #include "egl_dmabuf.h"
-+#include "kwineglext.h"
- #include "texture.h"
- #include "composite.h"
- #include "egl_context_attribute_builder.h"
-@@ -49,16 +50,6 @@ eglBindWaylandDisplayWL_func eglBindWaylandDisplayWL = nullptr;
- eglUnbindWaylandDisplayWL_func eglUnbindWaylandDisplayWL = nullptr;
- eglQueryWaylandBufferWL_func eglQueryWaylandBufferWL = nullptr;
-
--#ifndef EGL_WAYLAND_BUFFER_WL
--#define EGL_WAYLAND_BUFFER_WL 0x31D5
--#endif
--#ifndef EGL_WAYLAND_PLANE_WL
--#define EGL_WAYLAND_PLANE_WL 0x31D6
--#endif
--#ifndef EGL_WAYLAND_Y_INVERTED_WL
--#define EGL_WAYLAND_Y_INVERTED_WL 0x31DB
--#endif
--
- AbstractEglBackend::AbstractEglBackend()
- : QObject(nullptr)
- , OpenGLBackend()
-diff --git a/platformsupport/scenes/opengl/egl_dmabuf.cpp b/platformsupport/scenes/opengl/egl_dmabuf.cpp
-index 3f75bc7..753f15e 100644
---- a/platformsupport/scenes/opengl/egl_dmabuf.cpp
-+++ b/platformsupport/scenes/opengl/egl_dmabuf.cpp
-@@ -21,10 +21,10 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
- #include "egl_dmabuf.h"
-
- #include "drm_fourcc.h"
-+#include "kwineglext.h"
- #include "../../../wayland_server.h"
-
- #include <unistd.h>
--#include <EGL/eglmesaext.h>
-
- namespace KWin
- {
-@@ -34,45 +34,6 @@ typedef EGLBoolean (*eglQueryDmaBufModifiersEXT_func) (EGLDisplay dpy, EGLint fo
- eglQueryDmaBufFormatsEXT_func eglQueryDmaBufFormatsEXT = nullptr;
- eglQueryDmaBufModifiersEXT_func eglQueryDmaBufModifiersEXT = nullptr;
-
--#ifndef EGL_EXT_image_dma_buf_import
--#define EGL_LINUX_DMA_BUF_EXT 0x3270
--#define EGL_LINUX_DRM_FOURCC_EXT 0x3271
--#define EGL_DMA_BUF_PLANE0_FD_EXT 0x3272
--#define EGL_DMA_BUF_PLANE0_OFFSET_EXT 0x3273
--#define EGL_DMA_BUF_PLANE0_PITCH_EXT 0x3274
--#define EGL_DMA_BUF_PLANE1_FD_EXT 0x3275
--#define EGL_DMA_BUF_PLANE1_OFFSET_EXT 0x3276
--#define EGL_DMA_BUF_PLANE1_PITCH_EXT 0x3277
--#define EGL_DMA_BUF_PLANE2_FD_EXT 0x3278
--#define EGL_DMA_BUF_PLANE2_OFFSET_EXT 0x3279
--#define EGL_DMA_BUF_PLANE2_PITCH_EXT 0x327A
--#define EGL_YUV_COLOR_SPACE_HINT_EXT 0x327B
--#define EGL_SAMPLE_RANGE_HINT_EXT 0x327C
--#define EGL_YUV_CHROMA_HORIZONTAL_SITING_HINT_EXT 0x327D
--#define EGL_YUV_CHROMA_VERTICAL_SITING_HINT_EXT 0x327E
--#define EGL_ITU_REC601_EXT 0x327F
--#define EGL_ITU_REC709_EXT 0x3280
--#define EGL_ITU_REC2020_EXT 0x3281
--#define EGL_YUV_FULL_RANGE_EXT 0x3282
--#define EGL_YUV_NARROW_RANGE_EXT 0x3283
--#define EGL_YUV_CHROMA_SITING_0_EXT 0x3284
--#define EGL_YUV_CHROMA_SITING_0_5_EXT 0x3285
--#endif // EGL_EXT_image_dma_buf_import
--
--#ifndef EGL_EXT_image_dma_buf_import_modifiers
--#define EGL_DMA_BUF_PLANE3_FD_EXT 0x3440
--#define EGL_DMA_BUF_PLANE3_OFFSET_EXT 0x3441
--#define EGL_DMA_BUF_PLANE3_PITCH_EXT 0x3442
--#define EGL_DMA_BUF_PLANE0_MODIFIER_LO_EXT 0x3443
--#define EGL_DMA_BUF_PLANE0_MODIFIER_HI_EXT 0x3444
--#define EGL_DMA_BUF_PLANE1_MODIFIER_LO_EXT 0x3445
--#define EGL_DMA_BUF_PLANE1_MODIFIER_HI_EXT 0x3446
--#define EGL_DMA_BUF_PLANE2_MODIFIER_LO_EXT 0x3447
--#define EGL_DMA_BUF_PLANE2_MODIFIER_HI_EXT 0x3448
--#define EGL_DMA_BUF_PLANE3_MODIFIER_LO_EXT 0x3449
--#define EGL_DMA_BUF_PLANE3_MODIFIER_HI_EXT 0x344A
--#endif // EGL_EXT_image_dma_buf_import_modifiers
--
- struct YuvPlane
- {
- int widthDivisor;
-diff --git a/platformsupport/scenes/opengl/kwineglext.h b/platformsupport/scenes/opengl/kwineglext.h
-new file mode 100644
-index 0000000..834701b
---- /dev/null
-+++ b/platformsupport/scenes/opengl/kwineglext.h
-@@ -0,0 +1,76 @@
-+/********************************************************************
-+ KWin - the KDE window manager
-+ This file is part of the KDE project.
-+
-+Copyright (C) 2018 Fredrik Höglund <fredrik@kde.org>
-+Copyright (C) 2020 Vlad Zahorodnii <vlad.zahorodnii@kde.org>
-+
-+This program is free software; you can redistribute it and/or modify
-+it under the terms of the GNU General Public License as published by
-+the Free Software Foundation; either version 2 of the License, or
-+(at your option) any later version.
-+
-+This program is distributed in the hope that it will be useful,
-+but WITHOUT ANY WARRANTY; without even the implied warranty of
-+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+GNU General Public License for more details.
-+
-+You should have received a copy of the GNU General Public License
-+along with this program. If not, see <http://www.gnu.org/licenses/>.
-+*********************************************************************/
-+
-+#ifndef KWINEGLEXT_H
-+#define KWINEGLEXT_H
-+
-+#include <EGL/eglext.h>
-+
-+#ifndef EGL_WL_bind_wayland_display
-+#define EGL_WAYLAND_BUFFER_WL 0x31D5
-+#define EGL_WAYLAND_PLANE_WL 0x31D6
-+#define EGL_TEXTURE_Y_U_V_WL 0x31D7
-+#define EGL_TEXTURE_Y_UV_WL 0x31D8
-+#define EGL_TEXTURE_Y_XUXV_WL 0x31D9
-+#define EGL_TEXTURE_EXTERNAL_WL 0x31DA
-+#define EGL_WAYLAND_Y_INVERTED_WL 0x31DB
-+#endif // EGL_WL_bind_wayland_display
-+
-+#ifndef EGL_EXT_image_dma_buf_import
-+#define EGL_LINUX_DMA_BUF_EXT 0x3270
-+#define EGL_LINUX_DRM_FOURCC_EXT 0x3271
-+#define EGL_DMA_BUF_PLANE0_FD_EXT 0x3272
-+#define EGL_DMA_BUF_PLANE0_OFFSET_EXT 0x3273
-+#define EGL_DMA_BUF_PLANE0_PITCH_EXT 0x3274
-+#define EGL_DMA_BUF_PLANE1_FD_EXT 0x3275
-+#define EGL_DMA_BUF_PLANE1_OFFSET_EXT 0x3276
-+#define EGL_DMA_BUF_PLANE1_PITCH_EXT 0x3277
-+#define EGL_DMA_BUF_PLANE2_FD_EXT 0x3278
-+#define EGL_DMA_BUF_PLANE2_OFFSET_EXT 0x3279
-+#define EGL_DMA_BUF_PLANE2_PITCH_EXT 0x327A
-+#define EGL_YUV_COLOR_SPACE_HINT_EXT 0x327B
-+#define EGL_SAMPLE_RANGE_HINT_EXT 0x327C
-+#define EGL_YUV_CHROMA_HORIZONTAL_SITING_HINT_EXT 0x327D
-+#define EGL_YUV_CHROMA_VERTICAL_SITING_HINT_EXT 0x327E
-+#define EGL_ITU_REC601_EXT 0x327F
-+#define EGL_ITU_REC709_EXT 0x3280
-+#define EGL_ITU_REC2020_EXT 0x3281
-+#define EGL_YUV_FULL_RANGE_EXT 0x3282
-+#define EGL_YUV_NARROW_RANGE_EXT 0x3283
-+#define EGL_YUV_CHROMA_SITING_0_EXT 0x3284
-+#define EGL_YUV_CHROMA_SITING_0_5_EXT 0x3285
-+#endif // EGL_EXT_image_dma_buf_import
-+
-+#ifndef EGL_EXT_image_dma_buf_import_modifiers
-+#define EGL_DMA_BUF_PLANE3_FD_EXT 0x3440
-+#define EGL_DMA_BUF_PLANE3_OFFSET_EXT 0x3441
-+#define EGL_DMA_BUF_PLANE3_PITCH_EXT 0x3442
-+#define EGL_DMA_BUF_PLANE0_MODIFIER_LO_EXT 0x3443
-+#define EGL_DMA_BUF_PLANE0_MODIFIER_HI_EXT 0x3444
-+#define EGL_DMA_BUF_PLANE1_MODIFIER_LO_EXT 0x3445
-+#define EGL_DMA_BUF_PLANE1_MODIFIER_HI_EXT 0x3446
-+#define EGL_DMA_BUF_PLANE2_MODIFIER_LO_EXT 0x3447
-+#define EGL_DMA_BUF_PLANE2_MODIFIER_HI_EXT 0x3448
-+#define EGL_DMA_BUF_PLANE3_MODIFIER_LO_EXT 0x3449
-+#define EGL_DMA_BUF_PLANE3_MODIFIER_HI_EXT 0x344A
-+#endif // EGL_EXT_image_dma_buf_import_modifiers
-+
-+#endif // KWINEGLEXT_H
---
-cgit v1.1
-
diff --git a/kde-plasma/kwin/files/kwin-5.18.5-qt-5.15.patch b/kde-plasma/kwin/files/kwin-5.18.5-qt-5.15.patch
deleted file mode 100644
index eb8f6617026c..000000000000
--- a/kde-plasma/kwin/files/kwin-5.18.5-qt-5.15.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From ec602e0c2a676aed0707c7fb7edfe964516dbc77 Mon Sep 17 00:00:00 2001
-From: Fabian Vogt <fabian@ritter-vogt.de>
-Date: Sun, 7 Jun 2020 18:05:21 +0200
-Subject: [PATCH] Fix the Plastik decoration with Qt 5.15
-
-The trick in qmldir no longer works with Qt 5.15, so use a more reliable
-approach. This way works with Qt 5.15 and also on previous versions of Qt.
----
- .../kdecorations/aurorae/themes/plastik/code/plastikplugin.cpp | 3 ++-
- plugins/kdecorations/aurorae/themes/plastik/code/qmldir | 3 ---
- 2 files changed, 2 insertions(+), 4 deletions(-)
-
-diff --git a/plugins/kdecorations/aurorae/themes/plastik/code/plastikplugin.cpp b/plugins/kdecorations/aurorae/themes/plastik/code/plastikplugin.cpp
-index 25d11251f..4304dcdc1 100644
---- a/plugins/kdecorations/aurorae/themes/plastik/code/plastikplugin.cpp
-+++ b/plugins/kdecorations/aurorae/themes/plastik/code/plastikplugin.cpp
-@@ -20,7 +20,8 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
-
- void PlastikPlugin::registerTypes(const char *uri)
- {
-- Q_UNUSED(uri)
-+ // Need to register something to tell Qt that it loaded (QTBUG-84571)
-+ qmlRegisterModule(uri, 1, 0);
- }
-
- void PlastikPlugin::initializeEngine(QQmlEngine *engine, const char *uri)
-diff --git a/plugins/kdecorations/aurorae/themes/plastik/code/qmldir b/plugins/kdecorations/aurorae/themes/plastik/code/qmldir
-index 49a4b402d..aa7bf16b3 100644
---- a/plugins/kdecorations/aurorae/themes/plastik/code/qmldir
-+++ b/plugins/kdecorations/aurorae/themes/plastik/code/qmldir
-@@ -1,5 +1,2 @@
- module org.kde.kwin.decorations.plastik
- plugin plastikplugin
--
--# we need to have at least one element of Qt is not able to find the plugin *shrug*
--Foo 1.0 Foo.qml
---
-2.27.0
-
diff --git a/kde-plasma/kwin/files/kwin-5.18.5-wayland-lockscreen-greeter.patch b/kde-plasma/kwin/files/kwin-5.18.5-wayland-lockscreen-greeter.patch
deleted file mode 100644
index ac4b9d24c8e1..000000000000
--- a/kde-plasma/kwin/files/kwin-5.18.5-wayland-lockscreen-greeter.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From 6f8b8efb338117ee197092e46b25b489b612257d Mon Sep 17 00:00:00 2001
-From: Vlad Zahorodnii <vlad.zahorodnii@kde.org>
-Date: Fri, 8 May 2020 11:26:27 +0300
-Subject: [wayland] Place lockscreen greeter above other windows
-
-Summary: BUG: 420802
-
-Reviewers: #kwin, davidedmundson
-
-Reviewed By: #kwin, davidedmundson
-
-Subscribers: apol, kwin
-
-Tags: #kwin
-
-Differential Revision: https://phabricator.kde.org/D29523
----
- abstract_client.cpp | 2 ++
- autotests/integration/lockscreen.cpp | 19 +++++++++++++++++++
- 2 files changed, 21 insertions(+)
-
-diff --git a/abstract_client.cpp b/abstract_client.cpp
-index ca6c422..48918e7 100644
---- a/abstract_client.cpp
-+++ b/abstract_client.cpp
-@@ -275,6 +275,8 @@ Layer AbstractClient::belongsToLayer() const
- // Since the desktop is also activated, nothing should be in the ActiveLayer, though
- if (isInternal())
- return UnmanagedLayer;
-+ if (isLockScreen())
-+ return UnmanagedLayer;
- if (isDesktop())
- return workspace()->showingDesktop() ? AboveLayer : DesktopLayer;
- if (isSplash()) // no damn annoying splashscreens
-diff --git a/autotests/integration/lockscreen.cpp b/autotests/integration/lockscreen.cpp
-index e258540..82cac09 100644
---- a/autotests/integration/lockscreen.cpp
-+++ b/autotests/integration/lockscreen.cpp
-@@ -62,6 +62,7 @@ private Q_SLOTS:
- void initTestCase();
- void init();
- void cleanup();
-+ void testStackingOrder();
- void testPointer();
- void testPointerButton();
- void testPointerAxis();
-@@ -223,6 +224,24 @@ void LockScreenTest::cleanup()
- Test::destroyWaylandConnection();
- }
-
-+void LockScreenTest::testStackingOrder()
-+{
-+ // This test verifies that the lockscreen greeter is placed above other windows.
-+
-+ QSignalSpy clientAddedSpy(waylandServer(), &WaylandServer::shellClientAdded);
-+ QVERIFY(clientAddedSpy.isValid());
-+
-+ LOCK
-+ QVERIFY(clientAddedSpy.wait());
-+
-+ AbstractClient *client = clientAddedSpy.first().first().value<AbstractClient *>();
-+ QVERIFY(client);
-+ QVERIFY(client->isLockScreen());
-+ QCOMPARE(client->layer(), UnmanagedLayer);
-+
-+ UNLOCK
-+}
-+
- void LockScreenTest::testPointer()
- {
- using namespace KWayland::Client;
---
-cgit v1.1
diff --git a/kde-plasma/kwin/kwin-5.18.5-r1.ebuild b/kde-plasma/kwin/kwin-5.18.5-r1.ebuild
deleted file mode 100644
index 33ac47b0ae2a..000000000000
--- a/kde-plasma/kwin/kwin-5.18.5-r1.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_HANDBOOK="optional"
-ECM_TEST="optional"
-KFMIN=5.66.0
-PVCUT=$(ver_cut 1-3)
-QTMIN=5.12.3
-VIRTUALX_REQUIRED="test"
-inherit ecm kde.org
-
-DESCRIPTION="Flexible, composited Window Manager for windowing systems on Linux"
-
-LICENSE="GPL-2+"
-SLOT="5"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
-IUSE="caps gles2-only multimedia"
-
-COMMON_DEPEND="
- >=kde-frameworks/kactivities-${KFMIN}:5
- >=kde-frameworks/kauth-${KFMIN}:5
- >=kde-frameworks/kcmutils-${KFMIN}:5
- >=kde-frameworks/kcompletion-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/kcrash-${KFMIN}:5
- >=kde-frameworks/kdeclarative-${KFMIN}:5
- >=kde-frameworks/kglobalaccel-${KFMIN}:5=
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kiconthemes-${KFMIN}:5
- >=kde-frameworks/kidletime-${KFMIN}:5=
- >=kde-frameworks/kinit-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/knewstuff-${KFMIN}:5
- >=kde-frameworks/knotifications-${KFMIN}:5
- >=kde-frameworks/kpackage-${KFMIN}:5
- >=kde-frameworks/kservice-${KFMIN}:5
- >=kde-frameworks/ktextwidgets-${KFMIN}:5
- >=kde-frameworks/kwayland-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kwindowsystem-${KFMIN}:5[X]
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- >=kde-frameworks/plasma-${KFMIN}:5
- >=kde-plasma/breeze-${PVCUT}:5
- >=kde-plasma/kdecoration-${PVCUT}:5
- >=kde-plasma/kscreenlocker-${PVCUT}:5
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5=[gles2-only=]
- >=dev-qt/qtscript-${QTMIN}:5
- >=dev-qt/qtsensors-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtx11extras-${QTMIN}:5
- >=dev-libs/libinput-1.9
- >=dev-libs/wayland-1.2
- media-libs/fontconfig
- media-libs/freetype
- media-libs/libepoxy
- media-libs/mesa[egl,gbm,wayland,X(+)]
- virtual/libudev:=
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libdrm
- >=x11-libs/libxcb-1.10
- >=x11-libs/libxkbcommon-0.7.0
- x11-libs/xcb-util-cursor
- x11-libs/xcb-util-image
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-wm
- caps? ( sys-libs/libcap )
- gles2-only? ( media-libs/mesa[gles2] )
-"
-RDEPEND="${COMMON_DEPEND}
- >=kde-frameworks/kirigami-${KFMIN}:5
- >=dev-qt/qtquickcontrols-${QTMIN}:5
- >=dev-qt/qtquickcontrols2-${QTMIN}:5
- >=dev-qt/qtvirtualkeyboard-${QTMIN}:5
- multimedia? ( >=dev-qt/qtmultimedia-${QTMIN}:5[gstreamer,qml] )
-"
-DEPEND="${COMMON_DEPEND}
- >=dev-qt/designer-${QTMIN}:5
- >=dev-qt/qtconcurrent-${QTMIN}:5
- x11-base/xorg-proto
-"
-PDEPEND="
- >=kde-plasma/kde-cli-tools-${PVCUT}:5
-"
-
-RESTRICT+=" test"
-
-PATCHES=(
- # in Plasma/5.18
- "${FILESDIR}/${P}-dont-exec-QDialog.patch" # KDE-bug 421053
- "${FILESDIR}/${P}-wayland-lockscreen-greeter.patch" # KDE-bug 420802
-)
-
-src_prepare() {
- ecm_src_prepare
- use multimedia || eapply "${FILESDIR}/${PN}-5.16.80-gstreamer-optional.patch"
-
- # Access violations, bug #640432
- sed -e "s/^ecm_find_qmlmodule.*QtMultimedia/#&/" \
- -i CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package caps Libcap)
- )
-
- ecm_src_configure
-}
diff --git a/kde-plasma/kwin/kwin-5.18.5-r3.ebuild b/kde-plasma/kwin/kwin-5.18.5-r3.ebuild
deleted file mode 100644
index ed5d1d1f83c3..000000000000
--- a/kde-plasma/kwin/kwin-5.18.5-r3.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_HANDBOOK="optional"
-ECM_TEST="optional"
-KFMIN=5.66.0
-PVCUT=$(ver_cut 1-3)
-QTMIN=5.12.3
-VIRTUALX_REQUIRED="test"
-inherit ecm kde.org
-
-DESCRIPTION="Flexible, composited Window Manager for windowing systems on Linux"
-
-LICENSE="GPL-2+"
-SLOT="5"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE="caps gles2-only multimedia"
-
-COMMON_DEPEND="
- >=dev-libs/libinput-1.9
- >=dev-libs/wayland-1.2
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5=[gles2-only=]
- >=dev-qt/qtscript-${QTMIN}:5
- >=dev-qt/qtsensors-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtx11extras-${QTMIN}:5
- >=kde-frameworks/kactivities-${KFMIN}:5
- >=kde-frameworks/kauth-${KFMIN}:5
- >=kde-frameworks/kcmutils-${KFMIN}:5
- >=kde-frameworks/kcompletion-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/kcrash-${KFMIN}:5
- >=kde-frameworks/kdeclarative-${KFMIN}:5
- >=kde-frameworks/kglobalaccel-${KFMIN}:5=
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kiconthemes-${KFMIN}:5
- >=kde-frameworks/kidletime-${KFMIN}:5=
- >=kde-frameworks/kinit-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/knewstuff-${KFMIN}:5
- >=kde-frameworks/knotifications-${KFMIN}:5
- >=kde-frameworks/kpackage-${KFMIN}:5
- >=kde-frameworks/kservice-${KFMIN}:5
- >=kde-frameworks/ktextwidgets-${KFMIN}:5
- >=kde-frameworks/kwayland-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kwindowsystem-${KFMIN}:5[X]
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- >=kde-frameworks/plasma-${KFMIN}:5
- >=kde-plasma/breeze-${PVCUT}:5
- >=kde-plasma/kdecoration-${PVCUT}:5
- >=kde-plasma/kscreenlocker-${PVCUT}:5
- media-libs/fontconfig
- media-libs/freetype
- media-libs/libepoxy
- media-libs/mesa[egl,gbm,wayland,X(+)]
- virtual/libudev:=
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libdrm
- >=x11-libs/libxcb-1.10
- >=x11-libs/libxkbcommon-0.7.0
- x11-libs/xcb-util-cursor
- x11-libs/xcb-util-image
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-wm
- caps? ( sys-libs/libcap )
- gles2-only? ( media-libs/mesa[gles2] )
-"
-RDEPEND="${COMMON_DEPEND}
- >=dev-qt/qtquickcontrols-${QTMIN}:5
- >=dev-qt/qtquickcontrols2-${QTMIN}:5
- >=dev-qt/qtvirtualkeyboard-${QTMIN}:5
- >=kde-frameworks/kirigami-${KFMIN}:5
- multimedia? ( >=dev-qt/qtmultimedia-${QTMIN}:5[gstreamer,qml] )
-"
-DEPEND="${COMMON_DEPEND}
- >=dev-qt/designer-${QTMIN}:5
- >=dev-qt/qtconcurrent-${QTMIN}:5
- x11-base/xorg-proto
-"
-PDEPEND="
- >=kde-plasma/kde-cli-tools-${PVCUT}:5
-"
-
-RESTRICT+=" test"
-
-PATCHES=(
- # in Plasma/5.18
- "${FILESDIR}/${P}-dont-exec-QDialog.patch" # KDE-bug 421053
- "${FILESDIR}/${P}-wayland-lockscreen-greeter.patch" # KDE-bug 420802
- "${FILESDIR}/${P}-mesa-21.patch" # KDE-bug 422131
- "${FILESDIR}/${P}-qt-5.15.patch" # Plastik deco issue
-)
-
-src_prepare() {
- ecm_src_prepare
- use multimedia || eapply "${FILESDIR}/${PN}-5.16.80-gstreamer-optional.patch"
-
- # Access violations, bug #640432
- sed -e "s/^ecm_find_qmlmodule.*QtMultimedia/#&/" \
- -i CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package caps Libcap)
- )
-
- ecm_src_configure
-}