summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-13 19:57:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-13 20:43:12 +0100
commitd4fe789db1d07b9069fafd3728f09cfc325800d6 (patch)
treecaf29d096849a0b777c8c3a2383fc0666c6d11eb /kde-plasma/libksysguard
parentkde-frameworks/kholidays: Restore accidentally lost ~arm,~arm64 keywords (diff)
downloadgentoo-d4fe789db1d07b9069fafd3728f09cfc325800d6.tar.gz
gentoo-d4fe789db1d07b9069fafd3728f09cfc325800d6.tar.bz2
gentoo-d4fe789db1d07b9069fafd3728f09cfc325800d6.zip
kde-plasma: Add KDE Plasma 5.12.1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'kde-plasma/libksysguard')
-rw-r--r--kde-plasma/libksysguard/Manifest1
-rw-r--r--kde-plasma/libksysguard/libksysguard-5.12.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-plasma/libksysguard/Manifest b/kde-plasma/libksysguard/Manifest
index f528c2e28e55..408af2a9c624 100644
--- a/kde-plasma/libksysguard/Manifest
+++ b/kde-plasma/libksysguard/Manifest
@@ -1,2 +1,3 @@
DIST libksysguard-5.11.5.tar.xz 576200 BLAKE2B 8e17dc3eda1a69ea2a37664c80695c77087779138e8b4b99c9ab0ae444074d9f78194db55b00170d3d917310c0c1ccbc5c77d3aa07dbb2a31210ff4e8a9155c3 SHA512 3a4c08aba07a71841643fc830a77ae4684ed41a8f26e6222d202738fb3c9f7ee2e816f15bcbbf5b3032fc100d33feb4d6771bf335c70548ab3bb4440d6d90286
DIST libksysguard-5.12.0.tar.xz 569792 BLAKE2B 2a103699d11d9d9031a59de6a910a8dc557eb296e2e5c665dfa671e3cd551254fe3aaa24eaf0c9a637ca2f0c08d7d3aba1b12eb5a8ef3a76f6ff0229cfd2e976 SHA512 ad8f78e9b5f9f473667559bff060f1cd6daa086c2033c617223f906cd808224b9dca103ddb48f8f4ec9fd708cb557af50e066a4da43719711f52ed9bf1d42a57
+DIST libksysguard-5.12.1.tar.xz 567868 BLAKE2B ca56fdfac583917bb1f0fdf269ec1373940abb020370c68e3992af4e1454ff868d0b37a906a04437e78a5d0c3d6e2637c8e9191d439682d87c5f75a8d2c921c7 SHA512 e40ae55ab3c6001f69849b3ef1594ec954003e3d63f3d198575aa378fbf363d58d4911ef7ce26d4038fe585e8118086436741b7e1359311e2708a0ab679be37a
diff --git a/kde-plasma/libksysguard/libksysguard-5.12.1.ebuild b/kde-plasma/libksysguard/libksysguard-5.12.1.ebuild
new file mode 100644
index 000000000000..ec1440424001
--- /dev/null
+++ b/kde-plasma/libksysguard/libksysguard-5.12.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Task management and system monitoring library"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+detailedmemory minimal X"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ sys-libs/zlib
+ detailedmemory? ( $(add_qt_dep qtwebkit) )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ x11-libs/libXres
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-plasma/ksysguard:4
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kiconthemes)
+ !minimal? ( $(add_frameworks_dep plasma) )
+ X? ( x11-proto/xproto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package detailedmemory Qt5WebKitWidgets)
+ $(cmake-utils_use_find_package !minimal KF5Plasma)
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}