summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-12 13:02:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-12 13:03:26 +0200
commit9d72b9cc56d6c34c819ba50b6c92d1e4c44752bc (patch)
tree563579d8bc7dac01bc0b7a89ed630f53e14b1656 /kde-plasma/oxygen/oxygen-5.13.5-r1.ebuild
parentgames-engines/residualvm: Bump to version 0.3.1 (diff)
downloadgentoo-9d72b9cc56d6c34c819ba50b6c92d1e4c44752bc.tar.gz
gentoo-9d72b9cc56d6c34c819ba50b6c92d1e4c44752bc.tar.bz2
gentoo-9d72b9cc56d6c34c819ba50b6c92d1e4c44752bc.zip
kde-plasma/oxygen: Fix incorrect symlinks
Closes: https://bugs.gentoo.org/629550 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-plasma/oxygen/oxygen-5.13.5-r1.ebuild')
-rw-r--r--kde-plasma/oxygen/oxygen-5.13.5-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/oxygen/oxygen-5.13.5-r1.ebuild b/kde-plasma/oxygen/oxygen-5.13.5-r1.ebuild
new file mode 100644
index 000000000000..607c3ab579a3
--- /dev/null
+++ b/kde-plasma/oxygen/oxygen-5.13.5-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Oxygen visual style for the Plasma desktop"
+HOMEPAGE="https://cgit.kde.org/oxygen.git"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="wayland"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep frameworkintegration)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_plasma_dep kdecoration)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ wayland? ( $(add_frameworks_dep kwayland) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kservice)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-plasma/kdebase-cursors:4
+"
+
+PATCHES=( "${FILESDIR}/${P}-symlinks.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+ kde5_src_configure
+}