summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-08 13:40:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-08 14:32:55 +0100
commit5e0f583660d70d633152b9639af6b52e6f690090 (patch)
tree361e6c35245cbfb031ee399a9d3d441768480d8e /kde-plasma/oxygen
parentdev-lang/ruby: Added sys-libs/readline to RDEPEND. (diff)
downloadgentoo-5e0f583660d70d633152b9639af6b52e6f690090.tar.gz
gentoo-5e0f583660d70d633152b9639af6b52e6f690090.tar.bz2
gentoo-5e0f583660d70d633152b9639af6b52e6f690090.zip
kde-plasma: Add KDE Plasma 5.14.5
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/oxygen')
-rw-r--r--kde-plasma/oxygen/Manifest1
-rw-r--r--kde-plasma/oxygen/oxygen-5.14.5.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/kde-plasma/oxygen/Manifest b/kde-plasma/oxygen/Manifest
index a7f9046fb9ed..94bae1d8a07d 100644
--- a/kde-plasma/oxygen/Manifest
+++ b/kde-plasma/oxygen/Manifest
@@ -1,2 +1,3 @@
DIST oxygen-5.14.3.tar.xz 4479292 BLAKE2B 5c1a0c9b3abd7c5823081b7a1b69d510ebab297a9573c066285107ebedeb23a1eb7ccf6811e11322278d5f4940dfa7ff5273a59610f7ec97883b3e4100f74516 SHA512 9ea74fed0228d9431cef6e51fb24a7c59c4070055ae10ee87b25c04b01c7652df97bb7f09b62402cfa71ad27936905b9db3a1a69f73710f40683c5b33a302336
DIST oxygen-5.14.4.tar.xz 4468560 BLAKE2B e67f7cd832fbd04e2d8c0f3c5e3157d36bd77e590379cfa40f6f881167831c0a30af846ff1cb663242c976e09b5338ac15c9ed578e95db7dd701389f8f140b34 SHA512 bc7362a90507730a4e7a7f8a0bafaabc47789c6cbd3b42931349abf2584abad77603fe4c6c1d49e6ca7c09a408c0620008dadf448f335985003bc4d1a23bf76b
+DIST oxygen-5.14.5.tar.xz 4467780 BLAKE2B e43f1663f16f1c0886f43ced1c8382254144eed256ad80e4c9eb025a11c1e4cb5f3a543cc61f3ae7dcf30f6519ce4857ae1ddffda607b411c43b404504c9faf6 SHA512 b4cab5dbce0828e7a080cb458b00603ddebf9bb4ce5fce9ccf07a0dcee030ee268b9a6c53592035eb15251edb4ccf14dcf0fa921370f76d4cbcca355400d479d
diff --git a/kde-plasma/oxygen/oxygen-5.14.5.ebuild b/kde-plasma/oxygen/oxygen-5.14.5.ebuild
new file mode 100644
index 000000000000..c1c4116f67ba
--- /dev/null
+++ b/kde-plasma/oxygen/oxygen-5.14.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Oxygen visual style for the Plasma desktop"
+HOMEPAGE="https://cgit.kde.org/oxygen.git"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="wayland"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep frameworkintegration)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_plasma_dep kdecoration)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ wayland? ( $(add_frameworks_dep kwayland) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kservice)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-plasma/kdebase-cursors:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+ kde5_src_configure
+}