summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-06-10 14:49:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-06-10 17:29:54 +0200
commit3000ea0d8fc20e6e41fe5b6ac8cadb9db9fb14a1 (patch)
tree763831f96a13aa18b8f281767a568f22e59b49ce /kde-plasma/plasma-integration/plasma-integration-5.22.0.ebuild
parentkde-plasma/plasma-firewall: 5.22.0 version bump (diff)
downloadgentoo-3000ea0d8fc20e6e41fe5b6ac8cadb9db9fb14a1.tar.gz
gentoo-3000ea0d8fc20e6e41fe5b6ac8cadb9db9fb14a1.tar.bz2
gentoo-3000ea0d8fc20e6e41fe5b6ac8cadb9db9fb14a1.zip
kde-plasma/plasma-integration: 5.22.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-integration/plasma-integration-5.22.0.ebuild')
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.22.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.22.0.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.22.0.ebuild
new file mode 100644
index 000000000000..be95988540c6
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.22.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.82.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+# requires running kde environment
+RESTRICT+=" test"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"