summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-25 16:00:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-29 10:26:15 +0200
commit5da0293ca71c4608b453b99db6a9202db5e87143 (patch)
treedb667399d40199eeede6caae148812fc855b351c /kde-plasma/plasma-integration
parentapp-portage/eix: Fix C++ standard to C++14 to fix code bugs (diff)
downloadgentoo-5da0293ca71c4608b453b99db6a9202db5e87143.tar.gz
gentoo-5da0293ca71c4608b453b99db6a9202db5e87143.tar.bz2
gentoo-5da0293ca71c4608b453b99db6a9202db5e87143.zip
kde-plasma: Add KDE Plasma 5.12.7
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.12.7.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index cf9fa0eadd50..81b660085131 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,3 +1,4 @@
DIST plasma-integration-5.12.5.tar.xz 53664 BLAKE2B e37d44a0a33116ab1b2b1f1edb74a8616ba33aa41438b93f9bf2f45abe5bb49cda57a579b35b8af94a171074387178888f5b80909e50e9c2be4a7a11a1eb0198 SHA512 5ae667a11ea85c6e9f353939bc22d84c36cbb53f053244a93e7c1d185d20452a7fc3d2afed65427ef938910fa537648006c2dda77346419a6a4492a2e292c787
DIST plasma-integration-5.12.6.tar.xz 53412 BLAKE2B 3acee7e76786ab570f5c001589137f85decf42bd6857c21a2448269d4735309dcdb7d1f5233ed8c95de4ff5c783a07950f9627525966ba33a47c889da658ddec SHA512 df231e8041fb94f01b0950890f784d118ca0aa1a34e7e483f78351de237cc2ba46a05be9c7addc5a2c5d319be7e17b6e2c5f171da28aa7cfd9b34b585a3c8155
+DIST plasma-integration-5.12.7.tar.xz 53776 BLAKE2B 578d644aed72e7166898db13e8e8209b0285c388fec47b82e0495239a0685e07a848b36991988d42758db2cf02c46962e4cf01335071ec60283e97bc553bfa45 SHA512 b33b1b2d044f36b3dad8bf854acb9a1f94be527c9c9b84d18a58323ab249a63276ee91553b6d92fd77b347a52d6dc4c10c080e0333dd31d4ef1f6058cb557fe0
DIST plasma-integration-5.13.5.tar.xz 53704 BLAKE2B e3bc607fa7270e8f4c7ea686fc4c44f1c47a476a596fa1db646fd3fa729cdd47adb13ae158f4bb2dcf6fecf4ae9feed982438a80b34cb11b9e9abada40d8d67a SHA512 84fadaadda3d91d0ce9a17a2e52dcbb459925a2b20555891219f878df490a52101591da956a06e6362e427a3298499f503924406c28286b4c1b1594f864a6db2
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.12.7.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.12.7.ebuild
new file mode 100644
index 000000000000..7a6f1d7272c4
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.12.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui 'dbus' '' '5=')
+ $(add_qt_dep qtquickcontrols2)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"