summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-07 08:45:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-07 08:46:27 +0100
commit1aa2873329d8a0591af59873f6a3d9573d9d2f85 (patch)
treef5b0004289d12f19f001c56da7dc020001937301 /kde-plasma/plasma-nm
parentprofiles: plasma: Add media-libs/mlt[frei0r] to package.use (diff)
downloadgentoo-1aa2873329d8a0591af59873f6a3d9573d9d2f85.tar.gz
gentoo-1aa2873329d8a0591af59873f6a3d9573d9d2f85.tar.bz2
gentoo-1aa2873329d8a0591af59873f6a3d9573d9d2f85.zip
kde-plasma: Add KDE Plasma 5.14.3
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.14.3.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index 5573d369b3b0..a7c8ae8c995f 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,3 +1,4 @@
DIST plasma-nm-5.12.7.tar.xz 707240 BLAKE2B d6355e2a0ce181144842871c9335a02968d53f95d587f5d7fa982de33e64d6642a2ef450ba98052526f5114777f516daa801b42424e8bd48d65f3a334eca7aa3 SHA512 1727a113c2c48485d2864ca48d4bf7b05cec8fdeaf41bca2c6c0820a8f5665b77530b846eba4512aebe7c13362573154146f94538bee533c268781e70c462e56
DIST plasma-nm-5.13.5.tar.xz 705984 BLAKE2B 0a00bb3696ebc4ee5f26746cb1c1e9ef14e456abf448faf17d8ddb919f272354a88969ac54447ac626640d260c8bc1c4ffe3a578e3d2683c5efdf80d9b7d9a4b SHA512 13c0c5c27a5d01cf20093f314ff620658688fb10dfa052419b54f37e6de20fc947b120c7c9f3df5b3e8f3d92a1e701674c917456dbfb681c94e06a1da0456ead
DIST plasma-nm-5.14.2.tar.xz 714120 BLAKE2B cd1898872990795a432bd2dd23afde5f6f6279f663229dfa4bb88fc8eb5600e3deb16b1f6489e054195d2a731e72d637ad41300d3b5dec8d3b678366faeccd99 SHA512 f015635a77dd7ca16a5930eebdb22cf64b830eeacefb6bff241f55981cf7c9457f1366755c431f13b97b29e58c4bbf227d7ffc06aa7a5f47eee0f28b09c8c5f2
+DIST plasma-nm-5.14.3.tar.xz 718288 BLAKE2B 6fc68e0bf8661519889bead3b816cd51159dd1f48fb4243e4e8adb2097d9297d33d8246947ac92170d0290855f8b80f344d1f456e24c1f2007fa5333b3fc7bea SHA512 6337c35407074c649645df447b0502fce853115514e28fd216be0738bb35c86c3ec8313780ef6d7e4df3836c44851d644a07190c2333a1bb583e612056bc22a2
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.14.3.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.14.3.ebuild
new file mode 100644
index 000000000000..86195daf5637
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.14.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5(+)]
+ net-misc/networkmanager[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-misc/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-plasma/plasma-nm:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}