summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-plasma/plasma-sdk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-plasma/plasma-sdk')
-rw-r--r--kde-plasma/plasma-sdk/Manifest1
-rw-r--r--kde-plasma/plasma-sdk/files/plasma-sdk-5.3.2-remove-qtwebkit.patch11
-rw-r--r--kde-plasma/plasma-sdk/metadata.xml5
-rw-r--r--kde-plasma/plasma-sdk/plasma-sdk-5.3.2.ebuild39
4 files changed, 56 insertions, 0 deletions
diff --git a/kde-plasma/plasma-sdk/Manifest b/kde-plasma/plasma-sdk/Manifest
new file mode 100644
index 000000000000..7c44169a9f45
--- /dev/null
+++ b/kde-plasma/plasma-sdk/Manifest
@@ -0,0 +1 @@
+DIST plasma-sdk-5.3.2.tar.xz 642108 SHA256 5f68cf38adf0c8d03478b0e467c6a144a632d9d519101afa22f2bdeed5ea738f SHA512 689ece9f2c3f03ec0311d70b108f547296bb24534bb349848eeb3e5e0a049e749ff75bf5ccdc0c762788d1778ac7f025e30344f76d73c3c6b1d44007527e6266 WHIRLPOOL 4c44a78121e84bc7e13491906c87da49eaf67e43955e8af96cdbdce73f8564a143e081acdff9367b320cf21bb0b9443b5a86691081d02f4ddcc3635c4245a5b4
diff --git a/kde-plasma/plasma-sdk/files/plasma-sdk-5.3.2-remove-qtwebkit.patch b/kde-plasma/plasma-sdk/files/plasma-sdk-5.3.2-remove-qtwebkit.patch
new file mode 100644
index 000000000000..6a5c8b0e9001
--- /dev/null
+++ b/kde-plasma/plasma-sdk/files/plasma-sdk-5.3.2-remove-qtwebkit.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt 2015-07-18 18:21:24.686994466 +0200
++++ b/CMakeLists.txt 2015-07-18 18:21:51.772993658 +0200
+@@ -24,7 +24,7 @@
+ # where to look first for cmake modules, before ${CMAKE_ROOT}/Modules/ is checked
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
+
+-find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core DBus Gui Qml Quick Svg WebKit WebKitWidgets Widgets Xml)
++find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core DBus Gui Qml Quick Svg Widgets Xml)
+
+ find_package(Qt5Test ${QT_MIN_VERSION} CONFIG QUIET)
+ set_package_properties(Qt5Test PROPERTIES
diff --git a/kde-plasma/plasma-sdk/metadata.xml b/kde-plasma/plasma-sdk/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/kde-plasma/plasma-sdk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>
diff --git a/kde-plasma/plasma-sdk/plasma-sdk-5.3.2.ebuild b/kde-plasma/plasma-sdk/plasma-sdk-5.3.2.ebuild
new file mode 100644
index 000000000000..493e53cf0a41
--- /dev/null
+++ b/kde-plasma/plasma-sdk/plasma-sdk-5.3.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Useful applications for Plasma development"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep plasma)
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+"
+RDEPEND="${DEPEND}
+ !dev-util/plasmate
+"
+
+PATCHES=( "${FILESDIR}/${P}-remove-qtwebkit.patch" )