summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-10-11 19:36:26 +0200
committerMichael Palimaka <kensington@gentoo.org>2016-10-13 05:06:35 +1100
commite559b1743038622ade87249c595dd945a2827b7f (patch)
tree3807d81d8966e59519e9fcaff8f72c1b101cbb82 /kde-plasma/plasma-workspace/files
parentkde-frameworks: remove 5.23.0 (diff)
downloadgentoo-e559b1743038622ade87249c595dd945a2827b7f.tar.gz
gentoo-e559b1743038622ade87249c595dd945a2827b7f.tar.bz2
gentoo-e559b1743038622ade87249c595dd945a2827b7f.zip
kde-plasma: 5.8.1 version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-plasma/plasma-workspace/files')
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.7.90-baloo-optional.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.7.90-baloo-optional.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.7.90-baloo-optional.patch
new file mode 100644
index 000000000000..34f7142dfdff
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.7.90-baloo-optional.patch
@@ -0,0 +1,41 @@
+commit 7ea5034dda3d7a497be8c8d1adea08897c165916
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Thu Sep 15 00:22:38 2016 +0200
+
+ Make KF5Baloo optional
+
+ https://mail.kde.org/pipermail/kde-frameworks-devel/2016-September/037734.html
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e57cb73..49584d9 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -26,8 +26,13 @@ find_package(KF5XmlRpcClient REQUIRED)
+ find_package(KF5 REQUIRED COMPONENTS PlasmaQuick)
+ find_package(KF5 REQUIRED COMPONENTS SysGuard)
+ find_package(KF5 REQUIRED COMPONENTS Package)
+-# Baloo has a different version scheme than KF5 for now
+-find_package(KF5 5.1 REQUIRED COMPONENTS Baloo)
++
++find_package(KF5Baloo)
++set_package_properties(KF5Baloo PROPERTIES DESCRIPTION "File Searching"
++ TYPE OPTIONAL
++ PURPOSE "Needed for the File Search runner."
++ )
++
+ find_package(KF5TextEditor)
+ find_package(KWinDBusInterface CONFIG REQUIRED)
+
+diff --git a/runners/CMakeLists.txt b/runners/CMakeLists.txt
+index 48cc379..d7656c8 100644
+--- a/runners/CMakeLists.txt
++++ b/runners/CMakeLists.txt
+@@ -1,5 +1,7 @@
+ add_subdirectory(activities)
+-add_subdirectory(baloo)
++if(KF5Baloo_FOUND)
++ add_subdirectory(baloo)
++endif()
+ add_subdirectory(bookmarks)
+ add_subdirectory(calculator)
+ add_subdirectory(locations)