summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-22 18:11:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-23 15:59:14 +0100
commit4f6eef277f8cb6faac8f0c75e7f8260599ed453f (patch)
treee4e467c95f68ff85846b89f6e80f090c95fba591 /kde-plasma/plasma-workspace
parentkde-plasma/plasma-desktop: Drop 5.23.3 (r0) (diff)
downloadgentoo-4f6eef277f8cb6faac8f0c75e7f8260599ed453f.tar.gz
gentoo-4f6eef277f8cb6faac8f0c75e7f8260599ed453f.tar.bz2
gentoo-4f6eef277f8cb6faac8f0c75e7f8260599ed453f.zip
kde-plasma/plasma-workspace: baloosearchruner: Emit DBus error
...when baloo is disabled KDE-bug: https://bugs.kde.org/show_bug.cgi?id=445342 Upstream commit afff43effadd78ab682ecf4c6c9919bdcbbedbcd Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-workspace')
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.23.3-baloosearchrunner-emit-DBus-error-when-disabled.patch75
-rw-r--r--kde-plasma/plasma-workspace/plasma-workspace-5.23.3-r2.ebuild210
2 files changed, 285 insertions, 0 deletions
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.23.3-baloosearchrunner-emit-DBus-error-when-disabled.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.23.3-baloosearchrunner-emit-DBus-error-when-disabled.patch
new file mode 100644
index 000000000000..be4b6e51b3e2
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.23.3-baloosearchrunner-emit-DBus-error-when-disabled.patch
@@ -0,0 +1,75 @@
+From afff43effadd78ab682ecf4c6c9919bdcbbedbcd Mon Sep 17 00:00:00 2001
+From: Alexander Lohnau <alexander.lohnau@gmx.de>
+Date: Fri, 12 Nov 2021 11:10:15 +0100
+Subject: [PATCH] baloosearchruner: Emit DBus error when baloo is disabled
+
+Otherwise we exit and KRunner runner into a long timeout.
+
+By making this a dedicated DBus error KRunner can also know, that this
+runner can not be started. Consequently making new attempts to query
+this runner can be prevented.
+
+Because the runner is DBus-Activated, we can not exit the process, otherwise other
+processes (like the search in the app launcher) will have the same issue with the timeout.
+BUG: 445342
+
+
+(cherry picked from commit fa5ac3fe3421a0077d9d80f52b89536daa732afa)
+---
+ runners/baloo/baloosearchrunner.cpp | 14 ++++++++++----
+ runners/baloo/baloosearchrunner.h | 2 +-
+ 2 files changed, 11 insertions(+), 5 deletions(-)
+
+diff --git a/runners/baloo/baloosearchrunner.cpp b/runners/baloo/baloosearchrunner.cpp
+index 08f24b362..768709cee 100644
+--- a/runners/baloo/baloosearchrunner.cpp
++++ b/runners/baloo/baloosearchrunner.cpp
+@@ -31,10 +31,6 @@ static const QString s_openParentDirId = QStringLiteral("openParentDir");
+
+ int main(int argc, char **argv)
+ {
+- Baloo::IndexerConfig config;
+- if (!config.fileIndexingEnabled()) {
+- return -1;
+- }
+ QCoreApplication::setAttribute(Qt::AA_DisableSessionManager);
+ QApplication::setQuitOnLastWindowClosed(false);
+ QApplication app(argc, argv); // KRun needs widgets for error message boxes
+@@ -60,11 +56,21 @@ SearchRunner::~SearchRunner()
+
+ RemoteActions SearchRunner::Actions()
+ {
++ Baloo::IndexerConfig config;
++ if (!config.fileIndexingEnabled()) {
++ sendErrorReply(QDBusError::ErrorType::NotSupported);
++ }
+ return RemoteActions({RemoteAction{s_openParentDirId, i18n("Open Containing Folder"), QStringLiteral("document-open-folder")}});
+ }
+
+ RemoteMatches SearchRunner::Match(const QString &searchTerm)
+ {
++ Baloo::IndexerConfig config;
++ if (!config.fileIndexingEnabled()) {
++ sendErrorReply(QDBusError::ErrorType::NotSupported);
++ return {};
++ }
++
+ // Do not try to show results for queries starting with =
+ // this should trigger the calculator, but the AdvancedQueryParser::parse method
+ // in baloo interpreted it as an operator, BUG 345134
+diff --git a/runners/baloo/baloosearchrunner.h b/runners/baloo/baloosearchrunner.h
+index 5006c9ae3..4836769c9 100644
+--- a/runners/baloo/baloosearchrunner.h
++++ b/runners/baloo/baloosearchrunner.h
+@@ -14,7 +14,7 @@
+ #include "dbusutils_p.h"
+ #include <KRunner/QueryMatch>
+
+-class SearchRunner : public QObject
++class SearchRunner : public QObject, protected QDBusContext
+ {
+ Q_OBJECT
+
+--
+GitLab
+
diff --git a/kde-plasma/plasma-workspace/plasma-workspace-5.23.3-r2.ebuild b/kde-plasma/plasma-workspace/plasma-workspace-5.23.3-r2.ebuild
new file mode 100644
index 000000000000..5bc9e1a28269
--- /dev/null
+++ b/kde-plasma/plasma-workspace/plasma-workspace-5.23.3-r2.ebuild
@@ -0,0 +1,210 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="forceoptional"
+KFMIN=5.86.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="KDE Plasma workspace"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="appstream +calculator +calendar +fontconfig geolocation gps screencast
++semantic-desktop telemetry"
+
+REQUIRED_USE="gps? ( geolocation )"
+RESTRICT="test"
+
+# slot op: various private QtWaylandClient headers
+COMMON_DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5[widgets]
+ >=dev-qt/qtgui-${QTMIN}:5=[jpeg,libinput]
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kactivities-${KFMIN}:5
+ >=kde-frameworks/kactivities-stats-${KFMIN}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kbookmarks-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kded-${KFMIN}:5
+ >=kde-frameworks/kglobalaccel-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kidletime-${KFMIN}:5
+ >=kde-frameworks/kinit-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kpeople-${KFMIN}:5
+ >=kde-frameworks/krunner-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktexteditor-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kunitconversion-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ >=kde-frameworks/prison-${KFMIN}:5[qml]
+ >=kde-frameworks/solid-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ >=kde-plasma/kscreenlocker-${PVCUT}:5
+ >=kde-plasma/kwin-${PVCUT}:5
+ >=kde-plasma/layer-shell-qt-${PVCUT}:5
+ >=kde-plasma/libkscreen-${PVCUT}:5
+ >=kde-plasma/libksysguard-${PVCUT}:5
+ >=kde-plasma/libkworkspace-${PVCUT}:5
+ >=media-libs/phonon-4.11.0
+ sys-libs/zlib
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ appstream? ( dev-libs/appstream[qt5] )
+ calculator? ( sci-libs/libqalculate:= )
+ calendar? ( >=kde-frameworks/kholidays-${KFMIN}:5 )
+ fontconfig? (
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ media-libs/fontconfig
+ x11-libs/libXft
+ x11-libs/xcb-util-image
+ )
+ geolocation? ( >=kde-frameworks/networkmanager-qt-${KFMIN}:5 )
+ gps? ( sci-geosciences/gpsd )
+ screencast? (
+ >=dev-qt/qtgui-${QTMIN}:5=[egl]
+ media-libs/libglvnd
+ >=media-video/pipewire-0.3:=
+ x11-libs/libdrm
+ )
+ semantic-desktop? ( >=kde-frameworks/baloo-${KFMIN}:5 )
+ telemetry? ( dev-libs/kuserfeedback:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.1.1
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-util/wayland-scanner-1.19.0
+ x11-base/xorg-proto
+ fontconfig? ( x11-libs/libXrender )
+"
+RDEPEND="${COMMON_DEPEND}
+ app-text/iso-codes
+ >=dev-qt/qdbus-${QTMIN}:5
+ >=dev-qt/qtgraphicaleffects-${QTMIN}:5
+ >=dev-qt/qtpaths-${QTMIN}:5
+ >=dev-qt/qtquickcontrols-${QTMIN}:5[widgets]
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ kde-apps/kio-extras:5
+ >=kde-frameworks/kdesu-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/kquickcharts-${KFMIN}:5
+ >=kde-plasma/milou-${PVCUT}:5
+ >=kde-plasma/plasma-integration-${PVCUT}:5
+ x11-apps/xmessage
+ x11-apps/xprop
+ x11-apps/xrdb
+ x11-apps/xsetroot
+ sys-apps/dbus
+ !<kde-plasma/breeze-5.22.90:5
+ !<kde-plasma/plasma-desktop-5.21.90:5
+"
+BDEPEND="virtual/pkgconfig"
+PDEPEND=">=kde-plasma/kde-cli-tools-${PVCUT}:5"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.21.5-split-libkworkspace.patch" # downstream
+ "${FILESDIR}/${PN}-5.22.5-krunner-cwd-at-home.patch" # TODO upstream: KDE-bug 432975, bug 767478
+ "${FILESDIR}/${P}-baloosearchrunner-emit-DBus-error-when-disabled.patch" # KDE-bug 445342
+)
+
+src_prepare() {
+ ecm_src_prepare
+
+ cmake_comment_add_subdirectory libkworkspace
+ # delete colliding libkworkspace translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -name "libkworkspace*" -delete || die
+ fi
+
+ # TODO: try to get a build switch upstreamed
+ if ! use screencast; then
+ sed -e "s/^pkg_check_modules.*PipeWire/#&/" -i CMakeLists.txt || die
+ fi
+
+ # KDE-bug: 433730
+ use calculator ||
+ cmake_run_in runners cmake_comment_add_subdirectory calculator
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_xembed-sni-proxy=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_PackageKitQt5=ON
+ $(cmake_use_find_package appstream AppStreamQt)
+ $(cmake_use_find_package calendar KF5Holidays)
+ $(cmake_use_find_package fontconfig Fontconfig)
+ $(cmake_use_find_package geolocation KF5NetworkManagerQt)
+ $(cmake_use_find_package semantic-desktop KF5Baloo)
+ $(cmake_use_find_package telemetry KUserFeedback)
+ )
+
+ use geolocation && mycmakeargs+=( $(cmake_use_find_package gps libgps) )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # default startup and shutdown scripts
+ insinto /etc/xdg/plasma-workspace/env
+ doins "${FILESDIR}"/10-agent-startup.sh
+
+ insinto /etc/xdg/plasma-workspace/shutdown
+ doins "${FILESDIR}"/10-agent-shutdown.sh
+ fperms +x /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh
+}
+
+pkg_postinst () {
+ ecm_pkg_postinst
+
+ elog "To enable gpg-agent and/or ssh-agent in Plasma sessions,"
+ elog "edit ${EPREFIX}/etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and ${EPREFIX}/etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+}