summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-29 21:43:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-29 23:21:35 +0100
commit484c9dded4c2473cc9cf94f0ea2f4b87ae3ee5fd (patch)
tree38d93021acd0016cf8d9e739e232b856cdaace75 /kde-plasma/xdg-desktop-portal-kde
parentprofiles: arm64: Add kde-plasma/plasma-meta[thunderbolt] to p.use.mask (diff)
downloadgentoo-484c9dded4c2473cc9cf94f0ea2f4b87ae3ee5fd.tar.gz
gentoo-484c9dded4c2473cc9cf94f0ea2f4b87ae3ee5fd.tar.bz2
gentoo-484c9dded4c2473cc9cf94f0ea2f4b87ae3ee5fd.zip
kde-plasma: Add KDE Plasma 5.17.2
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/xdg-desktop-portal-kde')
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/Manifest1
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.17.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/kde-plasma/xdg-desktop-portal-kde/Manifest b/kde-plasma/xdg-desktop-portal-kde/Manifest
index 64cf44edde99..5a0004c852dd 100644
--- a/kde-plasma/xdg-desktop-portal-kde/Manifest
+++ b/kde-plasma/xdg-desktop-portal-kde/Manifest
@@ -1,2 +1,3 @@
DIST xdg-desktop-portal-kde-5.16.5.tar.xz 61576 BLAKE2B b9d186e3269aae6c079bae8abf01e790300da5ba255ecaa37ca2b139bb5c017f0cc118adbaca8d4f846cfbf5d563d574cddca4703e9d917f7001468b27734db6 SHA512 381298cc001795902343512f8bb08c363acfb6e3ef398e0f170f305572ca9a5caaf458e85b6f48ac84bcd963a34e535c666b0ddc1bb910a894a8b8de8801467e
DIST xdg-desktop-portal-kde-5.17.1.tar.xz 62660 BLAKE2B 2a05547c3f269e9ffceb4e5cb9f20f8771dbf5ec8502d7c3ae1d54205fad7e12f02c462a2048dbff390b27fc498f2ea69c14ee4fe1ca96450be7f2661f9082a8 SHA512 9a9ebae7a0abdcd40f3ecb4965d04cc4506238f4685fea16e614c52bc82c4c1583d18d04e0708d7c5eac90df2635b86675e4bf9e73fb83b37d2700279dcd3c03
+DIST xdg-desktop-portal-kde-5.17.2.tar.xz 62924 BLAKE2B 20fc2265a162c420d99b82dfa8f170af4ad57442a30b60408a5d5dfd65742bb9fb76012afc55b6aba742cf7454fe381a25714991001963d5e4aa1da602f36f84 SHA512 45578698500bb67f3437380bba960204808b257b819c7579e7a0e8ad3d9eefb1244b5709a142b472fa8b0061032137968700d2f9bff5cdf74a97e977c4baa09f
diff --git a/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.17.2.ebuild b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.17.2.ebuild
new file mode 100644
index 000000000000..c388b6f4f5b6
--- /dev/null
+++ b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.17.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal that is using Qt/KDE Frameworks"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="screencast"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport 'cups')
+ $(add_qt_dep qtwidgets)
+ screencast? (
+ media-libs/libepoxy
+ media-libs/mesa[gbm]
+ media-video/pipewire:=
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kwayland)
+ $(add_qt_dep qtconcurrent)
+"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/xdg-desktop-portal[screencast?]
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package screencast PipeWire)
+ $(cmake-utils_use_find_package screencast GBM)
+ $(cmake-utils_use_find_package screencast Epoxy)
+ )
+ kde5_src_configure
+}