summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-07 19:27:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-07 23:08:18 +0100
commit6adb5443037382add02196d68c5612c9aa30693a (patch)
tree6588679e29e2e00df6cae5ab1e06329a49f46f2b /kde-plasma/xdg-desktop-portal-kde
parentmedia-libs/qtav: Fix build w/ Qt 5.14 (diff)
downloadgentoo-6adb5443037382add02196d68c5612c9aa30693a.tar.gz
gentoo-6adb5443037382add02196d68c5612c9aa30693a.tar.bz2
gentoo-6adb5443037382add02196d68c5612c9aa30693a.zip
kde-plasma: Add KDE Plasma 5.17.5
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/xdg-desktop-portal-kde')
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/Manifest1
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.17.5.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/xdg-desktop-portal-kde/Manifest b/kde-plasma/xdg-desktop-portal-kde/Manifest
index 77653a91ce28..d3d038242ae8 100644
--- a/kde-plasma/xdg-desktop-portal-kde/Manifest
+++ b/kde-plasma/xdg-desktop-portal-kde/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-kde-5.17.4.tar.xz 63064 BLAKE2B 14150aaf52629973192025e572c0b8444554023bff2a5dfd3cffebccad7a880c6490d79451e62a0997e411f45ea90fb5ad39dc39ba8917344c443d56582093e9 SHA512 2c4ce80e6a0bcc9486d1b3947c27f1af00870d6ffcf0b35c35bd7413683fae393f1b21646276c6200a41c2d5d98c84b440a8fdc3b0ac283466a45709fc151d1c
+DIST xdg-desktop-portal-kde-5.17.5.tar.xz 62912 BLAKE2B cc108a943c925c0943a4a391b4c00619d734837106c617d8dc12a21e890707dbd1aaace11dfa2ecd9b9a32a08dfba57b3baf1e7b33dec481a15e0fcc9f1abaf1 SHA512 b5a82d6744e49d2f6edb7bef2120f5517216dcbf8681cf50fb5522444f635d6cae17cf499310866e351ef9eaab35d37f604d241451a23fbd5f037e377cfd102c
diff --git a/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.17.5.ebuild b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.17.5.ebuild
new file mode 100644
index 000000000000..ab383c29457d
--- /dev/null
+++ b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.17.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.64.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal that is using Qt/KDE Frameworks"
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="screencast"
+
+COMMON_DEPEND="
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5[cups]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ screencast? (
+ media-libs/libepoxy
+ media-libs/mesa[gbm]
+ media-video/pipewire:=
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/xdg-desktop-portal[screencast?]
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package screencast PipeWire)
+ $(cmake_use_find_package screencast GBM)
+ $(cmake_use_find_package screencast Epoxy)
+ )
+ ecm_src_configure
+}