summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-25 15:29:30 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-25 18:23:49 +0100
commitae8c19f8d28c0946c5d5e92a32b944621d466bb6 (patch)
tree39974984dc3edd56b27110901d5e2998a600c122 /kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.18.2.ebuild
parentapp-crypt/qca: 2.3.0 version bump (diff)
downloadgentoo-ae8c19f8d28c0946c5d5e92a32b944621d466bb6.tar.gz
gentoo-ae8c19f8d28c0946c5d5e92a32b944621d466bb6.tar.bz2
gentoo-ae8c19f8d28c0946c5d5e92a32b944621d466bb6.zip
kde-plasma: Add KDE Plasma 5.18.2
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.18.2.ebuild')
-rw-r--r--kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.18.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.18.2.ebuild b/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.18.2.ebuild
new file mode 100644
index 000000000000..02431bf615d1
--- /dev/null
+++ b/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.18.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_ORG_NAME="plasma-workspace"
+KFMIN=5.66.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.12.3
+inherit cmake kde.org
+
+DESCRIPTION="Legacy xembed tray icons support for SNI-only system trays"
+HOMEPAGE="https://cgit.kde.org/plasma-workspace.git/tree/xembed-sni-proxy/Readme.md"
+
+LICENSE="GPL-2"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-qt/qtcore-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/extra-cmake-modules-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ x11-libs/libxcb
+ x11-libs/libXtst
+ x11-libs/xcb-util-image
+"
+RDEPEND="${DEPEND}
+ !<kde-plasma/plasma-workspace-5.14.2:5
+ !kde-plasma/xembed-sni-proxy:0
+"
+
+S="${S}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-5.14.90-standalone.patch" )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "/set/s/GENTOO_PV/$(ver_cut 1-3)/" \
+ -i CMakeLists.txt || die "Failed to prepare CMakeLists.txt"
+}