summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-10 15:01:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-11 14:40:22 +0200
commit0333cc1f5e5ac8c0153bbe3824d578316cc189a7 (patch)
treeeb37fca473612518d7543b6efd0a90aa883e392b /kde-plasma
parentkde-plasma/plasma-nm: add 5.26.0 (diff)
downloadgentoo-0333cc1f5e5ac8c0153bbe3824d578316cc189a7.tar.gz
gentoo-0333cc1f5e5ac8c0153bbe3824d578316cc189a7.tar.bz2
gentoo-0333cc1f5e5ac8c0153bbe3824d578316cc189a7.zip
kde-plasma/plasma-nm: Make kde-frameworks/kdeclarative RDEPEND-only
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-nm/files/plasma-nm-5.26.0-unused-dep.patch62
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.26.0.ebuild4
2 files changed, 65 insertions, 1 deletions
diff --git a/kde-plasma/plasma-nm/files/plasma-nm-5.26.0-unused-dep.patch b/kde-plasma/plasma-nm/files/plasma-nm-5.26.0-unused-dep.patch
new file mode 100644
index 000000000000..400a3fcdfc59
--- /dev/null
+++ b/kde-plasma/plasma-nm/files/plasma-nm-5.26.0-unused-dep.patch
@@ -0,0 +1,62 @@
+From 6f6958586e5a89ad5ff597550894a5770b5fb7cf Mon Sep 17 00:00:00 2001
+From: Volker Krause <vkrause@kde.org>
+Date: Wed, 5 Oct 2022 16:38:37 +0200
+Subject: [PATCH] Remove deprecated KDeclarative use
+
+The icon image engine seems not required here.
+---
+ CMakeLists.txt | 1 -
+ kcm/CMakeLists.txt | 1 -
+ kcm/kcm.cpp | 5 -----
+ 3 files changed, 7 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6495c735..c245f60e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -40,7 +40,6 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
+ ConfigWidgets
+ Completion
+ CoreAddons
+- Declarative
+ DBusAddons
+ KIO
+ I18n
+diff --git a/kcm/CMakeLists.txt b/kcm/CMakeLists.txt
+index cbd7ad32..8f3e60d3 100755
+--- a/kcm/CMakeLists.txt
++++ b/kcm/CMakeLists.txt
+@@ -16,7 +16,6 @@ target_link_libraries(kcm_networkmanagement
+ plasmanm_internal
+ plasmanm_editor
+ KF5::ConfigWidgets
+- KF5::Declarative
+ KF5::I18n
+ KF5::Service
+ Qt::Quick
+diff --git a/kcm/kcm.cpp b/kcm/kcm.cpp
+index 11663fe9..e350be54 100644
+--- a/kcm/kcm.cpp
++++ b/kcm/kcm.cpp
+@@ -20,7 +20,6 @@
+ #include <KPluginFactory>
+ #include <KPluginMetaData>
+ #include <KSharedConfig>
+-#include <kdeclarative/kdeclarative.h>
+
+ #include <NetworkManagerQt/ActiveConnection>
+ #include <NetworkManagerQt/Connection>
+@@ -58,10 +57,6 @@ KCMNetworkmanagement::KCMNetworkmanagement(QWidget *parent, const QVariantList &
+ auto mainWidget = new QWidget(this);
+ m_ui->setupUi(mainWidget);
+
+- KDeclarative::KDeclarative kdeclarative;
+- kdeclarative.setDeclarativeEngine(m_ui->connectionView->engine());
+- kdeclarative.setupEngine(m_ui->connectionView->engine());
+-
+ KLocalizedContext *l10nContext = new KLocalizedContext(m_ui->connectionView->engine());
+ l10nContext->setTranslationDomain(QStringLiteral(TRANSLATION_DOMAIN));
+ m_ui->connectionView->engine()->rootContext()->setContextObject(l10nContext);
+--
+2.38.0
+
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.26.0.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.26.0.ebuild
index 7324db7382cb..5b2a2bbb7629 100644
--- a/kde-plasma/plasma-nm/plasma-nm-5.26.0.ebuild
+++ b/kde-plasma/plasma-nm/plasma-nm-5.26.0.ebuild
@@ -28,7 +28,6 @@ DEPEND="
>=kde-frameworks/kconfigwidgets-${KFMIN}:5
>=kde-frameworks/kcoreaddons-${KFMIN}:5
>=kde-frameworks/kdbusaddons-${KFMIN}:5
- >=kde-frameworks/kdeclarative-${KFMIN}:5
>=kde-frameworks/ki18n-${KFMIN}:5
>=kde-frameworks/kio-${KFMIN}:5
>=kde-frameworks/kitemviews-${KFMIN}:5
@@ -56,6 +55,7 @@ DEPEND="
RDEPEND="${DEPEND}
>=dev-qt/qtquickcontrols-${QTMIN}:5
>=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
>=kde-frameworks/kirigami-${KFMIN}:5
>=kde-frameworks/kquickcharts-${KFMIN}:5
>=kde-plasma/kde-cli-tools-${PVCUT}:5
@@ -65,6 +65,8 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=( "${FILESDIR}/${P}-unused-dep.patch" )
+
src_prepare() {
ecm_src_prepare