summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-02-28 02:25:13 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-03-03 06:23:19 +1100
commit185acb067688322b0dbdeaf73cee0a9ac0a9f6a6 (patch)
treea927e5b4d5bbee2b738997b408073c3d09ca3ff8 /kde-plasma
parentkde-apps/kdebase-runtime-meta: Add USE=pam for new kwalletd-pam dependency (diff)
downloadgentoo-185acb067688322b0dbdeaf73cee0a9ac0a9f6a6.tar.gz
gentoo-185acb067688322b0dbdeaf73cee0a9ac0a9f6a6.tar.bz2
gentoo-185acb067688322b0dbdeaf73cee0a9ac0a9f6a6.zip
kde-plasma/kwallet-pam: Add pkg_postinst instructions
Package-Manager: portage-2.2.27
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.4.3-r1.ebuild27
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.5.4.ebuild25
2 files changed, 51 insertions, 1 deletions
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.4.3-r1.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.4.3-r1.ebuild
index 26499e685320..42f80332a989 100644
--- a/kde-plasma/kwallet-pam/kwallet-pam-5.4.3-r1.ebuild
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.4.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -20,3 +20,28 @@ DEPEND="
RDEPEND="${DEPEND}
net-misc/socat
"
+
+pkg_postinst() {
+ check_dm() {
+ if [[ -e "${ROOT}${2}" ]] && \
+ [[ -n $(egrep "auth\s+optional\s+pam_kwallet5.so" "${ROOT}${2}") ]] && \
+ [[ -n $(egrep "session\s+optional\s+pam_kwallet5.so" "${ROOT}${2}") ]]; then
+ elog " ${1} - ${2} ...GOOD"
+ else
+ ewarn " ${1} - ${2} ...BAD"
+ fi
+ }
+ elog
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "List of things to make it work:"
+ elog "1. Use same password for login and kwallet"
+ elog "2. A display manager with support for PAM"
+ elog "3.a Have the following lines in the display manager's pam.d file:"
+ elog " -auth optional pam_kwallet5.so"
+ elog " -session optional pam_kwallet5.so auto_start"
+ elog "3.b Checking installed DMs..."
+ has_version "x11-misc/sddm" && check_dm "SDDM" "/etc/pam.d/sddm"
+ has_version "x11-misc/lightdm" && check_dm "LightDM" "/etc/pam.d/lightdm"
+ has_version "kde-base/kdm" && check_dm "KDM" "/etc/pam.d/kde"
+ elog
+}
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.5.4.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.5.4.ebuild
index 69759db15c52..50ad31edcf76 100644
--- a/kde-plasma/kwallet-pam/kwallet-pam-5.5.4.ebuild
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.5.4.ebuild
@@ -27,3 +27,28 @@ src_configure() {
kde5_src_configure
}
+
+pkg_postinst() {
+ check_dm() {
+ if [[ -e "${ROOT}${2}" ]] && \
+ [[ -n $(egrep "auth\s+optional\s+pam_kwallet5.so" "${ROOT}${2}") ]] && \
+ [[ -n $(egrep "session\s+optional\s+pam_kwallet5.so" "${ROOT}${2}") ]]; then
+ elog " ${1} - ${2} ...GOOD"
+ else
+ ewarn " ${1} - ${2} ...BAD"
+ fi
+ }
+ elog
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "List of things to make it work:"
+ elog "1. Use same password for login and kwallet"
+ elog "2. A display manager with support for PAM"
+ elog "3.a Have the following lines in the display manager's pam.d file:"
+ elog " -auth optional pam_kwallet5.so"
+ elog " -session optional pam_kwallet5.so auto_start"
+ elog "3.b Checking installed DMs..."
+ has_version "x11-misc/sddm" && check_dm "SDDM" "/etc/pam.d/sddm"
+ has_version "x11-misc/lightdm" && check_dm "LightDM" "/etc/pam.d/lightdm"
+ has_version "kde-base/kdm" && check_dm "KDM" "/etc/pam.d/kde"
+ elog
+}