summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-05-17 21:00:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-05-17 21:01:50 +0200
commit742c530bfd9690468d841364bc48e5e2d5b0e36f (patch)
treead920c5f52c19c76df24170e19f39549d4c293c1 /kde-plasma
parentkde-plasma/kwayland-server: Fix supported action initialization (diff)
downloadgentoo-742c530bfd9690468d841364bc48e5e2d5b0e36f.tar.gz
gentoo-742c530bfd9690468d841364bc48e5e2d5b0e36f.tar.bz2
gentoo-742c530bfd9690468d841364bc48e5e2d5b0e36f.zip
kde-plasma/systemsettings: Backport several 5.24.6 fixes
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/systemsettings/files/systemsettings-5.24.5-fix-activating-running-instance-on-wayland.patch27
-rw-r--r--kde-plasma/systemsettings/files/systemsettings-5.24.5-fix-kcm-highlighting.patch32
-rw-r--r--kde-plasma/systemsettings/systemsettings-5.24.5-r1.ebuild65
3 files changed, 124 insertions, 0 deletions
diff --git a/kde-plasma/systemsettings/files/systemsettings-5.24.5-fix-activating-running-instance-on-wayland.patch b/kde-plasma/systemsettings/files/systemsettings-5.24.5-fix-activating-running-instance-on-wayland.patch
new file mode 100644
index 000000000000..c52f043133b7
--- /dev/null
+++ b/kde-plasma/systemsettings/files/systemsettings-5.24.5-fix-activating-running-instance-on-wayland.patch
@@ -0,0 +1,27 @@
+From c48ecf5efb941cb3056da8f2c074005cb87417aa Mon Sep 17 00:00:00 2001
+From: Nicolas Fella <nicolas.fella@gmx.de>
+Date: Thu, 12 May 2022 16:49:55 +0200
+Subject: [PATCH] Fix activating running instance on Wayland
+
+(cherry picked from commit 16c1ee0c517164867d004c561d403e3aebebc7e3)
+---
+ app/main.cpp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/app/main.cpp b/app/main.cpp
+index 13a803cd..e3f7b004 100644
+--- a/app/main.cpp
++++ b/app/main.cpp
+@@ -172,7 +172,8 @@ int main(int argc, char *argv[])
+ mainWindow->reloadStartupModule();
+ }
+
+- KWindowSystem::forceActiveWindow(mainWindow->winId());
++ KWindowSystem::updateStartupId(mainWindow->windowHandle());
++ KWindowSystem::activateWindow(mainWindow->windowHandle());
+ });
+
+ if (!startupModule.isEmpty()) {
+--
+GitLab
+
diff --git a/kde-plasma/systemsettings/files/systemsettings-5.24.5-fix-kcm-highlighting.patch b/kde-plasma/systemsettings/files/systemsettings-5.24.5-fix-kcm-highlighting.patch
new file mode 100644
index 000000000000..9f8d494ded69
--- /dev/null
+++ b/kde-plasma/systemsettings/files/systemsettings-5.24.5-fix-kcm-highlighting.patch
@@ -0,0 +1,32 @@
+From 684004217fd28ba45f7ce61df5b3600398ee1108 Mon Sep 17 00:00:00 2001
+From: Nicolas Fella <nicolas.fella@gmx.de>
+Date: Thu, 12 May 2022 01:22:14 +0200
+Subject: [PATCH] Fix current index in subcategory list
+
+We bind currentIndex to activeSubCategoryRow, but when clicking on an item this binding is broken
+
+Manually set the current index when the backend index changes
+
+BUG: 453543
+
+Fixed-In: 5.24.6
+(cherry picked from commit 40b71c085f8ceddc9b3f44fa65d8bb48dad42b4a)
+---
+ sidebar/package/contents/ui/SubCategoryPage.qml | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/sidebar/package/contents/ui/SubCategoryPage.qml b/sidebar/package/contents/ui/SubCategoryPage.qml
+index 756b2763..19b33142 100644
+--- a/sidebar/package/contents/ui/SubCategoryPage.qml
++++ b/sidebar/package/contents/ui/SubCategoryPage.qml
+@@ -140,6 +140,7 @@ Kirigami.ScrollablePage {
+ Connections {
+ target: systemsettings
+ function onActiveSubCategoryRowChanged() {
++ subCategoryView.currentIndex = systemsettings.activeSubCategoryRow
+ if (systemsettings.activeSubCategoryRow >= 0) {
+ if (subCategoryView.count > 1) {
+ root.pageStack.push(subCategoryColumn);
+--
+GitLab
+
diff --git a/kde-plasma/systemsettings/systemsettings-5.24.5-r1.ebuild b/kde-plasma/systemsettings/systemsettings-5.24.5-r1.ebuild
new file mode 100644
index 000000000000..ab73d76a6c65
--- /dev/null
+++ b/kde-plasma/systemsettings/systemsettings-5.24.5-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+KFMIN=5.90.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Control Center to configure KDE Plasma desktop"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5[widgets]
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kactivities-${KFMIN}:5
+ >=kde-frameworks/kactivities-stats-${KFMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/krunner-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-plasma/libkworkspace-${PVCUT}:5
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-kcm-highlighting.patch" # KDE-bug 453543
+ "${FILESDIR}/${P}-fix-activating-running-instance-on-wayland.patch"
+)
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Configure looks for GTK+" kde-plasma/kde-gtk-config
+ fi
+ ecm_pkg_postinst
+}