summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-07-22 09:33:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-07-22 09:36:17 +0200
commitcdcbaf25b1e164c0dd087443e282453cdf6748d0 (patch)
treed71adb663c56be4c50dd830ed6004387b14cb9fd /kde-plasma
parentdev-python/llvmlite: Reintroduce llvmlite-0.1{5,6}.0 (diff)
downloadgentoo-cdcbaf25b1e164c0dd087443e282453cdf6748d0.tar.gz
gentoo-cdcbaf25b1e164c0dd087443e282453cdf6748d0.tar.bz2
gentoo-cdcbaf25b1e164c0dd087443e282453cdf6748d0.zip
kde-plasma/khotkeys: Fix build with cmake-3.9
Reported-by: Perfect Gentleman <perfect007gentleman@gmail.com> Gentoo-bug: 625744 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/khotkeys/files/khotkeys-5.10.4-cmake-3.9.patch60
-rw-r--r--kde-plasma/khotkeys/khotkeys-5.10.4.ebuild2
2 files changed, 62 insertions, 0 deletions
diff --git a/kde-plasma/khotkeys/files/khotkeys-5.10.4-cmake-3.9.patch b/kde-plasma/khotkeys/files/khotkeys-5.10.4-cmake-3.9.patch
new file mode 100644
index 000000000000..541a184ec8db
--- /dev/null
+++ b/kde-plasma/khotkeys/files/khotkeys-5.10.4-cmake-3.9.patch
@@ -0,0 +1,60 @@
+From db3a04289d0f33285c3ca2d8fc05fc5bb45d608f Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Wed, 19 Jul 2017 22:28:32 +0200
+Subject: Make sure the dbus xml interface file exists before it's used
+
+Summary:
+This started to happen with cmake 3.9, producing this erorr:
+*** No rule to make target 'app/org.kde.khotkeys.xml', needed by
+'kcm_hotkeys/khotkeys_interface.cpp'."
+
+Test Plan: Builds fine with cmake 3.9.
+
+Reviewers: #plasma
+
+Subscribers: plasma-devel
+
+Tags: #plasma
+
+Differential Revision: https://phabricator.kde.org/D6792
+---
+ app/CMakeLists.txt | 8 ++++++--
+ kcm_hotkeys/CMakeLists.txt | 1 +
+ 2 files changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
+index 0e6609f..2c1485e 100644
+--- a/app/CMakeLists.txt
++++ b/app/CMakeLists.txt
+@@ -1,10 +1,14 @@
+ ########### next target ###############
+
++set(dbus_interface_name org.kde.khotkeys.xml)
+ set(kded_khotkeys_PART_SRCS
+ kded.cpp
+- ${CMAKE_CURRENT_BINARY_DIR}/org.kde.khotkeys.xml)
++ ${CMAKE_CURRENT_BINARY_DIR}/${dbus_interface_name})
+
+-qt5_generate_dbus_interface(kded.h org.kde.khotkeys.xml )
++qt5_generate_dbus_interface(kded.h ${dbus_interface_name})
++set(dbus_interface_xml ${CMAKE_CURRENT_BINARY_DIR}/${dbus_interface_name})
++
++add_custom_target(khotkeysdbusinterface ALL DEPENDS ${dbus_interface_name})
+
+ add_library(kded_khotkeys MODULE ${kded_khotkeys_PART_SRCS})
+ set_target_properties(kded_khotkeys PROPERTIES OUTPUT_NAME khotkeys)
+diff --git a/kcm_hotkeys/CMakeLists.txt b/kcm_hotkeys/CMakeLists.txt
+index f0ef3d3..0df2b5c 100644
+--- a/kcm_hotkeys/CMakeLists.txt
++++ b/kcm_hotkeys/CMakeLists.txt
+@@ -82,6 +82,7 @@ add_library(
+ MODULE
+ ${kcm_hotkeys_PART_SRCS}
+ )
++add_dependencies(kcm_hotkeys khotkeysdbusinterface)
+
+ target_compile_definitions(kcm_hotkeys PRIVATE -DPROJECT_VERSION="${PROJECT_VERSION}")
+
+--
+cgit v0.11.2
+
diff --git a/kde-plasma/khotkeys/khotkeys-5.10.4.ebuild b/kde-plasma/khotkeys/khotkeys-5.10.4.ebuild
index 95b8eaf17fd0..aab836444049 100644
--- a/kde-plasma/khotkeys/khotkeys-5.10.4.ebuild
+++ b/kde-plasma/khotkeys/khotkeys-5.10.4.ebuild
@@ -44,3 +44,5 @@ DEPEND="${COMMON_DEPEND}
x11-libs/libXtst
x11-proto/xproto
"
+
+PATCHES=( "${FILESDIR}/${P}-cmake-3.9.patch" )