summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-30 19:11:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-30 19:22:11 +0200
commite71b6df109fb99ae46412b8d03c422e9bd3f6867 (patch)
tree6893f72090a410453abe705b85788fb979cf9a17 /kde-plasma
parentmedia-libs/kimageannotator: bump to 0.5.2 (diff)
downloadgentoo-e71b6df109fb99ae46412b8d03c422e9bd3f6867.tar.gz
gentoo-e71b6df109fb99ae46412b8d03c422e9bd3f6867.tar.bz2
gentoo-e71b6df109fb99ae46412b8d03c422e9bd3f6867.zip
kde-plasma/plasma-workspace: Fix build with gpsd-3.23.1
See also: https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1078 Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.22.5-gpsd-3.23.1.patch30
-rw-r--r--kde-plasma/plasma-workspace/plasma-workspace-5.22.5-r2.ebuild1
2 files changed, 31 insertions, 0 deletions
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.22.5-gpsd-3.23.1.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.22.5-gpsd-3.23.1.patch
new file mode 100644
index 000000000000..cb35751d446f
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.22.5-gpsd-3.23.1.patch
@@ -0,0 +1,30 @@
+From e6cab5d96f7b51a5cf4be3d93a7e2d4fee1cddae Mon Sep 17 00:00:00 2001
+From: Vlad Zahorodnii <vlad.zahorodnii@kde.org>
+Date: Thu, 23 Sep 2021 19:29:05 +0300
+Subject: [PATCH] Fix build with gpsd 3.23.1
+
+STATUS_NO_FIX was renamed to STATUS_UNK.
+
+https://gitlab.com/gpsd/gpsd/-/commit/d4a4d8d3606fd50f10bcd20096a8a0cdb8b2d427
+---
+ dataengines/geolocation/location_gps.cpp | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/dataengines/geolocation/location_gps.cpp b/dataengines/geolocation/location_gps.cpp
+index 858059ada..ec9ec14ae 100644
+--- a/dataengines/geolocation/location_gps.cpp
++++ b/dataengines/geolocation/location_gps.cpp
+@@ -52,7 +52,9 @@ void Gpsd::run()
+ #else
+ if (m_gpsdata->online) {
+ #endif
+-#if GPSD_API_MAJOR_VERSION >= 10
++#if defined(STATUS_UNK) // STATUS_NO_FIX was renamed to STATUS_UNK without bumping API version
++ if (m_gpsdata->fix.status != STATUS_UNK) {
++#elif GPSD_API_MAJOR_VERSION >= 10
+ if (m_gpsdata->fix.status != STATUS_NO_FIX) {
+ #else
+ if (m_gpsdata->status != STATUS_NO_FIX) {
+--
+GitLab
+
diff --git a/kde-plasma/plasma-workspace/plasma-workspace-5.22.5-r2.ebuild b/kde-plasma/plasma-workspace/plasma-workspace-5.22.5-r2.ebuild
index 2a5454791b8e..21b2c64d565a 100644
--- a/kde-plasma/plasma-workspace/plasma-workspace-5.22.5-r2.ebuild
+++ b/kde-plasma/plasma-workspace/plasma-workspace-5.22.5-r2.ebuild
@@ -151,6 +151,7 @@ PATCHES=(
"${FILESDIR}/${P}-krunner-cwd-at-home.patch" # TODO upstream: KDE-bug 432975, bug 767478
"${FILESDIR}/${P}-fix-powermanagement-inhibition.patch" # KDE-bug 433675
"${FILESDIR}/${P}-fix-hotplug-notifications.patch" # KDE-bug 438874, bug 814284
+ "${FILESDIR}/${P}-gpsd-3.23.1.patch"
)
src_prepare() {